php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77817 PDO_INFORMIX 1.3.3 will not work with Informix 14.10.FC1.LNX
Submitted: 2019-03-29 02:24 UTC Modified: 2019-03-29 07:41 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: eric at madrid dot lol Assigned:
Status: Open Package: PDO_INFORMIX (PECL)
PHP Version: 7.3.3 OS: OpenSuSE Leap 15.0
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2019-03-29 02:24 UTC] eric at madrid dot lol
Description:
------------
I was wanting to upgrade from 12.10 iif.12.10.FC12DE.linux-x86_64 to 14.10 ibm.ids.14.10.FC1.LNX.tar

When I ./configure I get no:
"/home/informix/incl/cli/"
"/home/informix/lib/cli/"
"/home/informix/lib/esql/"

Attached: dir.txt are the files I copied to get ./configure & make to give no errors, but does not work...

I took these files and directories from the 12.10 system.
./configure no errors
make no errors
make install no errors

Does not show up in phpinfo()... works fine on 12.10 but not 14.10

Also FYI: on openSuSE Leap 15.0 the PDO says Version 1.3.2 on 12.10 Informix


Test script:
---------------
N/A

Expected result:
----------------
N/A


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-03-29 07:41 UTC] cmb@php.net
-Package: PDO related +Package: PDO_INFORMIX
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Apr 23 18:01:26 2019 UTC