php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #77807 Misuse of 'i.e.' instead of 'e.g.' in $_SERVER docs
Submitted: 2019-03-27 13:35 UTC Modified: 2019-03-27 17:57 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: markamery at btinternet dot com Assigned: cmb (profile)
Status: Closed Package: *General Issues
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2019-03-27 13:35 UTC] markamery at btinternet dot com
Description:
------------
The docs at https://www.php.net/manual/en/reserved.variables.server.php state that the REQUEST_METHOD variable contains:

    Which request method was used to access the page; i.e. 'GET', 'HEAD', 'POST', 'PUT'.

Read literally, this seems to mean that it can only ever hold one of those four specific values, which is of course not true. This apparently confused at least one person in the past: https://stackoverflow.com/a/10766284/1709587

To fix this, the "i.e." should simply be replaced by "e.g.".


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-03-27 17:57 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2019-03-27 17:57 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources[1]. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.

[1] <<http://svn.php.net/viewvc?view=revision&revision=347079>>
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Aug 20 19:01:29 2019 UTC