php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77728 pgort140.DLL missing
Submitted: 2019-03-12 14:31 UTC Modified: 2019-04-02 13:27 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: celestinoxp at hotmail dot com Assigned: cmb (profile)
Status: Closed Package: *General Issues
PHP Version: master-Git-2019-04-02 (snap) OS: Windows 10
Private report: No CVE-ID: None
 [2019-03-12 14:31 UTC] celestinoxp at hotmail dot com
Description:
------------
VC15 x86 Thread Safe (master/snapshot) for Windows have error pgort140.dll, when try use php...again!

Actual result:
--------------
PHP Error! pgort140.dll not found.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-03-12 17:13 UTC] cmb@php.net
-Summary: PHP not working! +Summary: pgort140.DLL missing -Assigned To: +Assigned To: ab
 [2019-03-12 17:13 UTC] cmb@php.net
I can confirm that php-master-ts-windows-vc15-x86-rdbb462d.zip
requires pgort140.DLL, but the DLL is missing.

Anatol, could you please have a look at this issue?
 [2019-03-15 11:27 UTC] celestinoxp at hotmail dot com
After 3 days, the problem has not yet been resolved!

PHP (Master) for Windows not working because pgort140.dll missing!
 [2019-03-18 17:35 UTC] cmb@php.net
-Assigned To: ab +Assigned To: cmb
 [2019-03-19 14:02 UTC] celestinoxp at hotmail dot com
php-master-ts-windows-vc15-x86-r44bb61f.zip

pgort140.dll missing!!!
 [2019-03-19 14:06 UTC] cmb@php.net
Sorry!  We're working on that.
 [2019-03-27 16:20 UTC] cmb@php.net
-Status: Assigned +Status: Closed
 [2019-03-27 16:20 UTC] cmb@php.net
This issue should now have been resolved (thanks to Anatol!) If it
should happen again, please re-open this ticket.  Thanks.
 [2019-04-02 10:40 UTC] celestinoxp at hotmail dot com
Problem started again in 01-April-2019 after revision "r6fccca5", i think.

Today (02-April-2019) no one revision works in windows.

System Info:
- Windows 10 (x86), 32-bits.

I related in past the same problem, and i give idea to create a test script when create compilation, script should test if have pgort140.dll missing, or not.
 [2019-04-02 10:43 UTC] celestinoxp at hotmail dot com
-Status: Closed +Status: Assigned -PHP Version: master-Git-2019-03-12 (snap) +PHP Version: master-Git-2019-04-02 (snap)
 [2019-04-02 10:43 UTC] celestinoxp at hotmail dot com
Problem started again in 01-April-2019 after revision "r6fccca5", i think.

Today (02-April-2019) no one revision works in windows.

System Info:
- Windows 10 (x86), 32-bits.

I related in past the same problem, and i give idea to create a test script when create compilation, script should test if have pgort140.dll missing, or not.
 [2019-04-02 13:27 UTC] cmb@php.net
-Status: Assigned +Status: Closed
 [2019-04-02 13:27 UTC] cmb@php.net
Thanks for reporting.  New snapshots builds are rolling and these
appear to be good so far.

> I related in past the same problem, and i give idea to create a
> test script when create compilation, script should test if have
> pgort140.dll missing, or not.

We're currently testing a different fix[1].

[1] <https://github.com/php/web-rmtools/pull/6>
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Oct 20 00:01:27 2019 UTC