php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77724 BG docs are broken
Submitted: 2019-03-11 12:37 UTC Modified: 2019-03-11 13:59 UTC
From: tufano at mail-pro dot info Assigned:
Status: Duplicate Package: Documentation problem
PHP Version: Irrelevant OS: any
Private report: No CVE-ID: None
 [2019-03-11 12:37 UTC] tufano at mail-pro dot info
Description:
------------
When landing on a previously supported Bulgarian version of a doc page, the docs render:

The manual page you are looking for (http://php.net/manual/bg/function.fgets.php) is not available on this server right now. Please check back later, or if the problem persists, contact the webmasters.


Example:
http://php.net/manual/bg/function.fgets.php


I can understand your point of not wanting to support Bulgarian for the documentation and I also support it. However, I am sure that you have removed the support of other languages as well but your pages continue to exist in Google's database and people will continue to land on these pages.

Instead of just printing that stupid page (which also suggests that the manual will come back, which wont happen), why not just 301 redirect visitors to the English version of the manual?

It's not too much to ask considering that its just a couple of lines for rewrite rules.

Thank you!


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-03-11 13:59 UTC] salathe@php.net
-Status: Open +Status: Duplicate
 [2019-03-11 13:59 UTC] salathe@php.net
Duplicate of bug #77637.  The redirect feature request is reasonable.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Nov 27 05:03:20 2021 UTC