php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77714 pcre_get_compiled_regex_cache->coredump
Submitted: 2019-03-09 03:45 UTC Modified: 2019-03-09 09:04 UTC
From: zhenglihao1 at 126 dot com Assigned: cmb (profile)
Status: Not a bug Package: FPM related
PHP Version: 7.1.15 OS: centos7
Private report: No CVE-ID: None
 [2019-03-09 03:45 UTC] zhenglihao1 at 126 dot com
Description:
------------
That rarely but certainly happened,gdb result below

(gdb) bt
#0  zend_hash_find_bucket (ht=ht@entry=0x119ed80 <pcre_globals>, ht=ht@entry=0x119ed80 <pcre_globals>, key=key@entry=0x7fab2f81bb00)
    at /opt/php-7.1.15/Zend/zend_hash.c:487
#1  zend_hash_find (ht=ht@entry=0x119ed80 <pcre_globals>, key=key@entry=0x7fab2f81bb00) at /opt/php-7.1.15/Zend/zend_hash.c:1958
#2  0x00000000004c5ed8 in zend_hash_find_ptr (key=0x7fab2f81bb00, ht=0x119ed80 <pcre_globals>) at /opt/php-7.1.15/Zend/zend_hash.h:735
#3  pcre_get_compiled_regex_cache (regex=0x7fab2f81bb00) at /opt/php-7.1.15/ext/pcre/php_pcre.c:354
#4  0x00000000004c7b09 in php_do_pcre_match (execute_data=0x7fab38e161c0, return_value=0x7fab38e161a0, global=0)
    at /opt/php-7.1.15/ext/pcre/php_pcre.c:716
#5  0x00000000008756c6 in ZEND_DO_ICALL_SPEC_RETVAL_USED_HANDLER () at /opt/php-7.1.15/Zend/zend_vm_execute.h:675
#6  0x00000000008658ab in execute_ex (ex=<optimized out>) at /opt/php-7.1.15/Zend/zend_vm_execute.h:429
#7  0x0000000000811311 in zend_call_function (fci=fci@entry=0x7ffc45727060, fci_cache=fci_cache@entry=0x7ffc45727030)
    at /opt/php-7.1.15/Zend/zend_execute_API.c:855
#8  0x000000000068d67d in reflection_method_invoke (execute_data=<optimized out>, return_value=0x7fab38e154e0, variadic=0)
    at /opt/php-7.1.15/ext/reflection/php_reflection.c:3342
#9  0x00000000008b6638 in ZEND_DO_FCALL_SPEC_RETVAL_USED_HANDLER () at /opt/php-7.1.15/Zend/zend_vm_execute.h:1097
#10 0x00000000008658ab in execute_ex (ex=<optimized out>) at /opt/php-7.1.15/Zend/zend_vm_execute.h:429
#11 0x00000000008b88c4 in zend_execute (op_array=0x7fab38f63000, op_array@entry=0x7fab3529ac68,
    return_value=return_value@entry=0x7fab38e15440) at /opt/php-7.1.15/Zend/zend_vm_execute.h:474
#12 0x00000000008208a4 in zend_execute_scripts (type=type@entry=8, retval=0x7fab38e15440, retval@entry=0x0, file_count=file_count@entry=3)
    at /opt/php-7.1.15/Zend/zend.c:1482
#13 0x00000000007c1700 in php_execute_script (primary_file=primary_file@entry=0x7ffc45729550) at /opt/php-7.1.15/main/main.c:2577
#14 0x000000000043dd9c in main (argc=<optimized out>, argv=<optimized out>) at /opt/php-7.1.15/sapi/fpm/fpm/fpm_main.c:1966


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-03-09 09:04 UTC] cmb@php.net
-Status: Open +Status: Not a bug -PHP Version: 7.1Git-2019-03-09 (snap) +PHP Version: 7.1.15 -Assigned To: +Assigned To: cmb
 [2019-03-09 09:04 UTC] cmb@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Nov 11 22:01:32 2019 UTC