php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77690 Unable to load dynamic library intl.
Submitted: 2019-03-04 03:36 UTC Modified: 2019-03-04 19:14 UTC
From: aaaaaki35 at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: *Extensibility Functions
PHP Version: 7.3.2 OS: Windows10
Private report: No CVE-ID: None
 [2019-03-04 03:36 UTC] aaaaaki35 at gmail dot com
Description:
------------
I would like to create a cakePHP project.
Therefore, I edited php.ini and enabled intl.
-; extension = intl
+ extension = intl
After editing, I confirmed the version of php, and the following was output.

----------------------------------------------------------------------------------------------------
PHP Warning:  PHP Startup: Unable to load dynamic library 'intl' (tried: C:\xampp\php\ext\intl (指定されたモジュールが見つかりません。), C:\xampp\php\ext\php_intl.dll (指定されたモジュールが見つかりません。)) in Unknown on line 0

Warning: PHP Startup: Unable to load dynamic library 'intl' (tried: C:\xampp\php\ext\intl (指定されたモジュールが見つか りません。), C:\xampp\php\ext\php_intl.dll (指定されたモジュールが見つかりません。)) in Unknown on line 0
----------------------------------------------------------------------------------------------------

"Php_intl.dll" existed in the specified directory.

When the version was changed to 7.2.5 and executed again, the above error was resolved.
Because there is a possibility of a degradation, I will report it.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-03-04 09:13 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2019-03-04 09:13 UTC] cmb@php.net
I can't reproduce this.  What does `php -v` report?
 [2019-03-04 12:55 UTC] aaaaaki35 at gmail dot com
-Status: Feedback +Status: Assigned
 [2019-03-04 12:55 UTC] aaaaaki35 at gmail dot com
`php -v` reports 
----------------------------------------------------------------------------------------------------
PHP Warning:  PHP Startup: Unable to load dynamic library 'intl' (tried: C:\xampp\php\ext\intl (指定されたモジュールが見つかりません。), C:\xampp\php\ext\php_intl.dll (指定されたモジュールが見つかりません。)) in Unknown on line 0

Warning: PHP Startup: Unable to load dynamic library 'intl' (tried: C:\xampp\php\ext\intl (指定されたモジュールが見つか りません。), C:\xampp\php\ext\php_intl.dll (指定されたモジュールが見つかりません。)) in Unknown on line 0
----------------------------------------------------------------------------------------------------
 [2019-03-04 13:01 UTC] spam2 at rhsoft dot net
"php -v" reports much more than the error message and it's hard to understand why people only copy&paste fragments instead uncutted input/output of asked command into bugreports
 [2019-03-04 13:08 UTC] aaaaaki35 at gmail dot com
Would you mind if I do not mind?

php -v
PHP Warning: PHP Startup: Unable to load dynamic library 'intl' (tried: C: \ xampp \ php \ ext \ intl (specified module not found), C: \ xampp \ php \ ext \ php_intl. dll (specified module not found)) in Unknown on line 0

W: PHP Startup: Unable to load dynamic library 'intl' (tried: C: \ xampp \ php \ ext \ intl (specified module not found), C: \ xampp \ php \ ext \ php_intl. dll (specified module not found)) in Unknown on line 0
PHP 7.3.2 (cli) (built: Feb 5 2019 22: 55: 35) (ZTS MSVC 15 (Visual C ++ 2017) x 64)
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.2, Copyright (c) 1998-2018 Zend Technologies
 [2019-03-04 13:16 UTC] spam2 at rhsoft dot net
> Would you mind if I do not mind?

ZTS MSVC 15 (Visual C ++ 2017) x 64
for example is important information

> C:\xampp\php\ext\

i bet everything that this is a packaging problem, the "intl" extension is just a wrapper and linked against libicu which needs to match on your system and all the stuff should be compiled with the same toolchain (Visual C ++ 2017)

here you go - older versions but pretty sure the same root cause
https://community.apachefriends.org/f/viewtopic.php?f=16&t=70125

this is the wrong bugtracker for binaries supplied by third parties
 [2019-03-04 13:21 UTC] aaaaaki35 at gmail dot com
Thank you for pointing out. Hereafter care.

Refer to the link destination.
Thank you very much.
 [2019-03-04 15:30 UTC] cmb@php.net
-Status: Assigned +Status: Not a bug
 [2019-03-04 15:30 UTC] cmb@php.net
> this is the wrong bugtracker for binaries supplied by third parties

That.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Nov 13 22:01:29 2019 UTC