php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77688 Stream filter 'convert.iconv.windows-1250/UTF-8' creates unicode code points
Submitted: 2019-03-01 18:34 UTC Modified: 2019-03-01 19:55 UTC
From: nerad dot peter at gmail dot com Assigned:
Status: Not a bug Package: ICONV related
PHP Version: 7.2.15 OS: Windows 10 64bit
Private report: No CVE-ID: None
 [2019-03-01 18:34 UTC] nerad dot peter at gmail dot com
Description:
------------
---
From manual page: https://php.net/book.iconv
---

Stream filter 'convert.iconv.windows-1250/UTF-8' creates unicode code points in result for example: ú -> \u00fa, š -> \u0161  .....




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-03-01 18:49 UTC] requinix@php.net
-Status: Open +Status: Feedback
 [2019-03-01 18:49 UTC] requinix@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc. If the script requires a 
database to demonstrate the issue, please make sure it creates 
all necessary tables, stored procedures etc.

Please avoid embedding huge scripts into the report.


 [2019-03-01 19:35 UTC] nerad dot peter at gmail dot com
-Status: Feedback +Status: Closed
 [2019-03-01 19:35 UTC] nerad dot peter at gmail dot com
My mistake.. there is no bug
 [2019-03-01 19:55 UTC] requinix@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 09 02:03:35 2021 UTC