php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77604 No pear.php.net
Submitted: 2019-02-11 16:08 UTC Modified: 2019-02-12 16:30 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: james at dustygroove dot com Assigned:
Status: Open Package: Website problem
PHP Version: Irrelevant OS: All
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2019-02-11 16:08 UTC] james at dustygroove dot com
Description:
------------
This subdomain is not available. 

Test script:
---------------
http://pear.php.net 
https://pear.php.net 
Click or cURL either link. 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-02-11 21:46 UTC] ramsey@php.net
-Status: Open +Status: Feedback
 [2019-02-11 21:46 UTC] ramsey@php.net
Please try loading it again. If it's still not loading, can you do a traceroute to see if you can find out where the request is getting stuck?
 [2019-02-11 23:38 UTC] ramsey@php.net
-Status: Feedback +Status: Open
 [2019-02-11 23:38 UTC] ramsey@php.net
I'm setting this back to "Open," since I'm experiencing some issues with https://pear.php.net, as well.

The website is loading, but it looks like none of the manual pages exist, and the PEAR PHAR file is not available, so attempting to build PHP with PEAR results in a failure (the rest of PHP builds fine, but the install-pear target fails). For example:



vagrant@ubuntu-bionic:/vagrant/php-src$ make install-pear
Installing PEAR environment:      /php/7.2/lib/php/
--2019-02-11 23:32:29--  https://pear.php.net/install-pear-nozlib.phar
Resolving pear.php.net (pear.php.net)... 109.203.101.62
Connecting to pear.php.net (pear.php.net)|109.203.101.62|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2019-02-11 23:32:29 ERROR 404: Not Found.

Makefile:451: recipe for target 'install-pear' failed
make: *** [install-pear] Error 8



When I try making a request to https://pear.php.net/install-pear-nozlib.phar, I get a 404.
 [2019-02-12 15:37 UTC] james at dustygroove dot com
Thanks for looking into this, the subdomain looks close to normal. I hadn't seen that the server was being rebuilt when I submitted the bug so I hope that worked out. Some documentation is missing, for example:

https://pear.php.net/package/Mail/

is available, however

https://pear.php.net/manual/en/package.mail.mail.php

(Documentation tab -> End-User Documentation link) is not found. 

https://pear.php.net/install-pear-nozlib.phar downloads fine and looks correct on our network but I haven't run the install on it.
 [2019-02-12 16:30 UTC] ramsey@php.net
> https://pear.php.net/install-pear-nozlib.phar downloads fine and looks correct on our network but I haven't run the install on it.

The PEAR folks were able to get that working again last night. :-)

https://twitter.com/pear/status/1095127586856943619

They're still working through the rest of the issues.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Apr 20 21:01:25 2019 UTC