php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77576 pull the libmagic implementation of gmtime_r
Submitted: 2019-02-06 10:08 UTC Modified: 2019-02-06 15:56 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: josh at semmle dot com Assigned: ab (profile)
Status: Closed Package: *Directory/Filesystem functions
PHP Version: master-Git-2019-02-06 (Git) OS: linux
Private report: No CVE-ID: None
 [2019-02-06 10:08 UTC] josh at semmle dot com
Description:
------------
See https://github.com/php/php-src/pull/3749. From comment there:

The functions without _r might have thread safety issues. None have been reported yet AFAIK. Libmagic itself is not thread safe btw. I didn't sync this part, because _r functions might be missing on some systems, thus it'll require to also pull the libmagic implementations (which are based on non _r functions anyway, and it'll require to integrate some configure checks to include the surrogate implementations from libmagic.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-02-06 15:54 UTC] ab@php.net
-Assigned To: +Assigned To: ab
 [2019-02-06 15:56 UTC] ab@php.net
-Package: Output Control +Package: *Directory/Filesystem functions
 [2019-02-06 15:56 UTC] ab@php.net
Related to the libmagic port.

Thanks.
 [2019-03-08 19:49 UTC] ab@php.net
Automatic comment on behalf of ab
Revision: http://git.php.net/?p=php-src.git;a=commit;h=65ffdc2adff1751d085288ca5df14625a69bd7f2
Log: Fixed bug #77576 pull the libmagic implementation of gmtime_r
 [2019-03-08 19:49 UTC] ab@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Apr 25 22:01:25 2019 UTC