php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77376 "undefined function" message no longer includes namespace
Submitted: 2018-12-30 16:36 UTC Modified: 2018-12-30 19:06 UTC
From: sjon at hortensius dot net Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 7.3.0 OS: archlinux
Private report: No CVE-ID: None
 [2018-12-30 16:36 UTC] sjon at hortensius dot net
Description:
------------
I found this while going through https://3v4l.org/bughunt/7.3.0/7.2.13+7.2.12. I couldn't find any reference to this in the changelog, so it seems to be a bug.

Test script:
---------------
See https://3v4l.org/KGf5M

namespace C;
Hello();

Expected result:
----------------
Fatal error: Uncaught Error: Call to undefined function C\Hello() in /in/KGf5M:3

Actual result:
--------------
Fatal error: Uncaught Error: Call to undefined function hello() in /in/KGf5M:3

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-12-30 19:06 UTC] cmb@php.net
-Package: *General Issues +Package: Scripting Engine problem
 [2018-12-30 19:06 UTC] cmb@php.net
It seems this behavioral change has been caused by commit
6fadb72[1].

[1] <http://git.php.net/?p=php-src.git;a=commit;h=6fadb72c0bf53844d4fccfb04af20fc4554c2189>
 [2019-01-02 07:33 UTC] laruence@php.net
Automatic comment on behalf of laruence@gmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=e01f08f679105b5fc80a6e65774731821227b66f
Log: Fixed bug #77376 (&quot;undefined function&quot; message no longer includes namespace)
 [2019-01-02 07:33 UTC] laruence@php.net
-Status: Open +Status: Closed
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Dec 12 22:01:25 2019 UTC