php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77368 createimagefromgif() function don't work normaly
Submitted: 2018-12-29 11:16 UTC Modified: 2019-02-26 15:27 UTC
From: caovietlam at gmail dot com Assigned:
Status: Suspended Package: GD related
PHP Version: 5.6.39 OS: Windows 10 Pro 64 bit
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2018-12-29 11:16 UTC] caovietlam at gmail dot com
Description:
------------
The source file 'anh.gif' is viewing normally in any photo viewer.
The destination files look so different with source file.
Still appear when test with PHP 7.3.0.

Test script:
---------------
<?php
	// Load image from test file
	$im = imagecreatefromgif('anh.gif');
	// Save to anothers format
	imagegif($im, 'test.gif');
	imagepng($im, 'test.png');
	imagejpeg($im, 'test.jpg');
	
?>

Expected result:
----------------
Destination files are similar with source when viewing.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-12-29 11:30 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2018-12-29 11:30 UTC] cmb@php.net
Please make the source file 'anh.gif' available for download from
somewhere else (this bugtracker does not allow to attach image
files).
 [2019-01-06 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 [2019-01-15 23:28 UTC] caovietlam at gmail dot com
-Status: No Feedback +Status: Closed
 [2019-01-15 23:28 UTC] caovietlam at gmail dot com
Here the link of file:
https://drive.google.com/file/d/1HAEMw9WxsMM0QOBKBjGKx0bS5gDVqc2H/view?usp=sharing
 [2019-01-15 23:49 UTC] caovietlam at gmail dot com
-Status: Closed +Status: Open
 [2019-01-15 23:49 UTC] caovietlam at gmail dot com
I apologize; I'm late.
Alert emails was moved to spam folder so I didn't receive feedback.
 [2019-01-16 12:51 UTC] cmb@php.net
-Status: Open +Status: Verified
 [2019-01-16 12:51 UTC] cmb@php.net
Thanks for the image!   I can confirm that the bottom of the image
is severly broken after the conversion.  I'll have a closer look
at this issue as soon as possible.
 [2019-01-17 10:46 UTC] caovietlam at gmail dot com
Thank you cmb@php.net .
I hope you can help in this matter.
Now I must use imagik library as a replacement.
 [2019-02-26 15:27 UTC] cmb@php.net
-Status: Verified +Status: Suspended -Assigned To: cmb +Assigned To:
 [2019-02-26 15:27 UTC] cmb@php.net
I haven't been able to solve the issue (yet); since this is not a
particular problem of PHP, but rather a general libgd issue, I've
forwarded to them[1], and suspend this ticket for the time being.

[1] <https://github.com/libgd/libgd/issues/498>
 [2019-02-27 03:58 UTC] caovietlam at gmail dot com
Thank for your help, cmb@php.net.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Jul 17 06:01:26 2019 UTC