php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77361 Configure fails on 64-bit AIX when opcache enabled
Submitted: 2018-12-27 22:03 UTC Modified: -
From: kadler at us dot ibm dot com Assigned:
Status: Closed Package: *Configuration Issues
PHP Version: 7.2.13 OS: AIX
Private report: No CVE-ID: None
 [2018-12-27 22:03 UTC] kadler at us dot ibm dot com
Description:
------------
configure fails on 64-bit AIX (or 32-bit with _LARGE_FILES enabled) *and* --enable-opcache=yes

checking "whether flock struct is linux ordered"... "no"
checking "whether flock struct is BSD ordered"... "no"
configure: error: Don't know how to define struct flock on this system, set --enable-opcache=no

This is a regression caused by f9048300123, as the configure check was altered to only check for Linux-style and BSD-style layouts. 32-bit AIX falls in to the Linux-style layout, so is unaffected. Of the hard-coded layout macros in ZendAccelerator.h, only 64-bit AIX does not fall in to the two cases checked for in the configure check.


Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-12-28 00:44 UTC]
The following pull request has been associated:

Patch Name: Fix bug #77361 (configure fails on 64-bit AIX when opcache enabled)
On GitHub:  https://github.com/php/php-src/pull/3723
Patch:      https://github.com/php/php-src/pull/3723.patch
 [2019-01-11 09:31 UTC] nikic@php.net
Automatic comment on behalf of kadler@us.ibm.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=332b58f86591548acd5965c7f7f0085af377f0d9
Log: Fix bug #77361 (configure fails on 64-bit AIX when opcache enabled)
 [2019-01-11 09:31 UTC] nikic@php.net
-Status: Open +Status: Closed
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Sep 18 09:01:27 2019 UTC