|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77288 configure bug with static openssl 1.1.1
Submitted: 2018-12-12 15:56 UTC Modified: -
Avg. Score:3.8 ± 0.7
Reproduced:6 of 6 (100.0%)
Same Version:5 (83.3%)
Same OS:6 (100.0%)
From: Assigned:
Status: Open Package: *Configuration Issues
PHP Version: 7.2.13 OS: Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
New email:
PHP Version: OS:


 [2018-12-12 15:56 UTC]
I run into an error when trying to configure PHP 7.2.13 with a static
openssl 1.1.1 library. The strange thing however is that using a static openssl
1.0.2 library works.

The error is as follows:

checking for OpenSSL version... >= 1.0.1
checking for CRYPTO_free in -lcrypto... yes
checking for SSL_CTX_set_ssl_version in -lssl... no
configure: error: libssl not found!

I've also tried to set:
export PKG_CONFIG_PATH=/usr/local/ssl-1.1.1/lib/pkgconfig/

But it did not help.

Here's my config.log:

So linking against a static openssl 1.0.2 works, but against a static
openssl 1.1.1 does not work.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2019-10-23 02:39 UTC]
For some strange reason the "-lpthread" in OPENSSL_LIBS is ignored. It is necessary though, because the configure process does not add it even though it's needed for openssl.

Adding it to LIBS solved the issue.

This is the command that finally worked (my static OpenSSL 1.1.1 is in /usr/local/ssl-1.1.1):

./configure [snip] --with-openssl=/usr/local/ssl-1.1.1 [snip]
CFLAGS=-I/usr/local/include LDFLAGS=-L/usr/local/lib LIBS="-lpthread"
OPENSSL_LIBS="-L/usr/local/ssl-1.1.1/lib -l:libssl.a -l:libcrypto.a -ldl
-lpthread" OPENSSL_CFLAGS="-I/usr/local/ssl-1.1.1/include"
 [2019-10-23 19:07 UTC]
Info from Jan Ehrhardt:

In the next releases (7.2.25 and 7.3.12) '-pthread' in OPENSSL_LIBS will not be ignored any longer for static openssl linking.
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 10 03:01:25 2020 UTC