php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #77258 preq_quote() started to quote '#' since 7.3 even though it's not listed in docu
Submitted: 2018-12-06 23:34 UTC Modified: 2018-12-06 23:43 UTC
From: wilkowski dot kontakt at gmail dot com Assigned:
Status: Not a bug Package: PCRE related
PHP Version: 7.3.0 OS: Windows 10
Private report: No CVE-ID: None
 [2018-12-06 23:34 UTC] wilkowski dot kontakt at gmail dot com
Description:
------------
preq_quote() started to quote '#' since 7.3 even though it's not listed in documentation

Test script:
---------------
echo preq_quote('#'); // results \# on 7.3+
echo preq_quote('#'); // results #  on any other


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-12-06 23:41 UTC] nikic@php.net
-Type: Bug +Type: Documentation Problem
 [2018-12-06 23:41 UTC] nikic@php.net
Intentional change, but of course needs to be documented.
 [2018-12-06 23:42 UTC] requinix@php.net
-Status: Open +Status: Not a bug -Type: Documentation Problem +Type: Bug
 [2018-12-06 23:42 UTC] requinix@php.net
It is in the Changelog.

You may be looking at a stale version in a mirror - wait a while.
 [2018-12-06 23:43 UTC] requinix@php.net
-Type: Bug +Type: Documentation Problem
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Apr 11 05:01:24 2021 UTC