php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77157 Attempting to download any PECL library gives a 500 error
Submitted: 2018-11-15 05:31 UTC Modified: 2018-11-15 06:33 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: php dot net at butt dot cx Assigned: petk (profile)
Status: Closed Package: PECL website (PECL)
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2018-11-15 05:31 UTC] php dot net at butt dot cx
Description:
------------
Visit a page on the PECL site, e.g. https://pecl.php.net/package/couchbase and try to download a TGZ. You get a 500, e.g. https://pecl.php.net/get/couchbase-2.6.0.tgz

Expected result:
----------------
To download the file

Actual result:
--------------
You get a 500

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-11-15 06:28 UTC] petk@php.net
Automatic comment on behalf of peterkokot@gmail.com
Revision: http://git.php.net/?p=web/pecl.git;a=commit;h=c54c36c2e324de10d066db132948345b4993f33a
Log: Fix #77157: Attempting to download any PECL library gives a 500 error
 [2018-11-15 06:28 UTC] petk@php.net
-Status: Open +Status: Closed
 [2018-11-15 06:32 UTC] petk@php.net
Hello, thank you for reporting issues. This should be now fixed with the next rsync update in about half an hour or so probably. I'll follow if there are any other issues. Caused by migrating to classes autoloading in the source code... Sorry for inconvenience. Regards and thank you for helping us make PHP better.
 [2018-11-15 06:33 UTC] petk@php.net
-Package: PECL +Package: PECL website -Assigned To: +Assigned To: petk
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Aug 09 17:01:23 2020 UTC