php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77150 ZIP Extension cannot be compiled against latest version of libzip
Submitted: 2018-11-14 10:35 UTC Modified: 2018-11-14 11:44 UTC
From: s dot pfalz at webcookies dot de Assigned: cmb (profile)
Status: Duplicate Package: Compile Failure
PHP Version: 7.2.12 OS: CentOS 7.5
Private report: No CVE-ID: None
 [2018-11-14 10:35 UTC] s dot pfalz at webcookies dot de
Description:
------------
If you compile the zip extension against the latest libzip Version 1.5.1a the compile run fails:

In file included from /opt/libzip/include/zip.h:45:0,
                 from /usr/src/php-7.2.12/ext/zip/php_zip.h:31,
                 from /usr/src/php-7.2.12/ext/zip/php_zip.c:36:
/usr/src/php-7.2.12/ext/zip/php_zip.c: In function ‘php_zip_object_free_storage’:
/opt/libzip/include/zipconf.h:14:30: error: invalid suffix "a" on integer constant
 #define LIBZIP_VERSION_MICRO 1a
                              ^
/usr/src/php-7.2.12/ext/zip/php_zip.c:1029:63: note: in expansion of macro ‘LIBZIP_VERSION_MICRO’
 #if LIBZIP_VERSION_MAJOR == 1 && LIBZIP_VERSION_MINOR == 3 && LIBZIP_VERSION_MICRO == 1
                                                               ^
/usr/src/php-7.2.12/ext/zip/php_zip.c: In function ‘c_ziparchive_close’:
/opt/libzip/include/zipconf.h:14:30: error: invalid suffix "a" on integer constant
 #define LIBZIP_VERSION_MICRO 1a
                              ^
/usr/src/php-7.2.12/ext/zip/php_zip.c:1542:63: note: in expansion of macro ‘LIBZIP_VERSION_MICRO’
 #if LIBZIP_VERSION_MAJOR == 1 && LIBZIP_VERSION_MINOR == 3 && LIBZIP_VERSION_MICRO == 1
                                                               ^
make: *** [ext/zip/php_zip.lo] Error 1
make: *** Waiting for unfinished jobs....

That's maybe an error on the libzip code itself using 1a as define, but I'm not sure so I'll post it here for reference.


Expected result:
----------------
Compile should be completed without a failure

Actual result:
--------------
Compile run failed.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-11-14 11:44 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2018-11-14 11:44 UTC] cmb@php.net
Duplicate of bug #76828.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Aug 18 03:01:28 2019 UTC