php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77139 intval gives wrong results
Submitted: 2018-11-11 18:06 UTC Modified: 2018-11-11 18:16 UTC
From: markus at senoner dot com Assigned: cmb (profile)
Status: Not a bug Package: *Math Functions
PHP Version: Irrelevant OS: Linux (any)
Private report: No CVE-ID: None
 [2018-11-11 18:06 UTC] markus at senoner dot com
Description:
------------
Please try:
echo intval(8.2*1000);
echo intval(8.2*100);
echo intval(8.2*10);
echo intval(8.2*1);

result:
8200
819   <--- this is wrong!
82
8

happens in PHP 7.2 as well as in PHP 5.X

If 819 is the result of an internal representation of 8.2 as 8.199999..., than why does the first operation in this example not give 8199 ?!?

Expected result:
----------------
8.2*100 should give 820, not 819


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-11-11 18:14 UTC] spam2 at rhsoft dot net
http://php.net/manual/de/language.types.float.php
 [2018-11-11 18:16 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2018-11-11 18:16 UTC] cmb@php.net
Floating point values have a limited precision. Hence a value might 
not have the same string representation after any processing. That also
includes writing a floating point value in your script and directly 
printing it without any mathematical operations.

If you would like to know more about "floats" and what IEEE
754 is, read this:
http://www.floating-point-gui.de/

Thank you for your interest in PHP.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Jan 19 21:01:24 2021 UTC