php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77122 Assertion failed: (((ht)->gc.refcount == 1)
Submitted: 2018-11-08 09:02 UTC Modified: 2021-09-21 12:37 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (50.0%)
From: abel dot zhou at hotmail dot com Assigned: cmb (profile)
Status: Not a bug Package: PECL (PECL)
PHP Version: 7.2.11 OS: osx
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
22 - 17 = ?
Subscribe to this entry?

 
 [2018-11-08 09:02 UTC] abel dot zhou at hotmail dot com
Description:
------------
When i use grpc extension to connection some golang grpc server.
---------------------------------------------------
class Client extends \Grpc\BaseStub {
    public function __construct($hostname, array $opts, $channel = null) {
        parent::__construct($hostname, $opts, $channel);
    }
}

------------------------------------------

Error:
Assertion failed: (((ht)->gc.refcount == 1) || ((ht)->u.flags & (1<<6))), function zend_hash_str_del, file /Users/xxx/opt/php-7.2.8/Zend/zend_hash.c, line 1162.


-----------------------------

The php version is 7.2.8.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-09-16 21:31 UTC] cmb@php.net
-Package: *Extensibility Functions +Package: PECL
 [2021-09-21 12:37 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2021-09-21 12:37 UTC] cmb@php.net
Please report PECL/grpc related issues to
<https://github.com/grpc/grpc/issues>.
This is not the proper place.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Oct 18 16:03:34 2021 UTC