php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77076 PHP 7.2 + OpenSSL 1.1.1 with deprecation warnings
Submitted: 2018-10-27 22:35 UTC Modified: 2018-10-28 11:40 UTC
From: dev dot dertin at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: Compile Warning
PHP Version: 7.2.11 OS: Debian 9.5
Private report: No CVE-ID: None
 [2018-10-27 22:35 UTC] dev dot dertin at gmail dot com
Description:
------------
Several warning are found in the compilation of PHP 7.2 together with the OpenSSL 1.1.1 library

Test environment information:

Debian 9.5

openssl	        1.1.1
python2	        2.7.15
zlib	        1.2.11
lz4	        1.8.3
libssh2	        1.8.0
nghttp2	        1.34.0
curl	        7.61.1
cmake	        3.12.3
libzip	        1.5.1
libcrack2	2.9.6
libxml2	        2.9.8
libxslt	        1.1.33-rc1
jemalloc	5.1.0
mariadb	        10.3
php	        7.2.11
nginx	        1.15.5

Test script:
---------------
Compile using the following script: 
https://github.com/dertin/lemp-stack-debian

Actual result:
--------------
/var/tmp/php_build/php_src/ext/openssl/xp_ssl.c: In function 'php_openssl_select_crypto_method':
/var/tmp/php_build/php_src/ext/openssl/xp_ssl.c:965:3: warning: 'TLSv1_client_method' is deprecated [-Wdeprecated-declarations]
   return is_client ? TLSv1_client_method() : TLSv1_server_method();
   ^~~~~~
In file included from /usr/local/include/openssl/e_os2.h:13:0,
                 from /usr/local/include/openssl/err.h:13,
                 from /var/tmp/php_build/php_src/ext/openssl/php_openssl.h:69,
                 from /var/tmp/php_build/php_src/ext/openssl/xp_ssl.c:32:
/usr/local/include/openssl/ssl.h:1854:1: note: declared here
 DEPRECATEDIN_1_1_0(__owur const SSL_METHOD *TLSv1_client_method(void))
 ^
/var/tmp/php_build/php_src/ext/openssl/xp_ssl.c:965:3: warning: 'TLSv1_server_method' is deprecated [-Wdeprecated-declarations]
   return is_client ? TLSv1_client_method() : TLSv1_server_method();
   ^~~~~~
In file included from /usr/local/include/openssl/e_os2.h:13:0,
                 from /usr/local/include/openssl/err.h:13,
                 from /var/tmp/php_build/php_src/ext/openssl/php_openssl.h:69,
                 from /var/tmp/php_build/php_src/ext/openssl/xp_ssl.c:32:
/usr/local/include/openssl/ssl.h:1853:1: note: declared here
 DEPRECATEDIN_1_1_0(__owur const SSL_METHOD *TLSv1_server_method(void))
 ^
/var/tmp/php_build/php_src/ext/openssl/xp_ssl.c:968:3: warning: 'TLSv1_1_client_method' is deprecated [-Wdeprecated-declarations]
   return is_client ? TLSv1_1_client_method() : TLSv1_1_server_method();
   ^~~~~~
In file included from /usr/local/include/openssl/e_os2.h:13:0,
                 from /usr/local/include/openssl/err.h:13,
                 from /var/tmp/php_build/php_src/ext/openssl/php_openssl.h:69,
                 from /var/tmp/php_build/php_src/ext/openssl/xp_ssl.c:32:
/usr/local/include/openssl/ssl.h:1860:1: note: declared here
 DEPRECATEDIN_1_1_0(__owur const SSL_METHOD *TLSv1_1_client_method(void))
 ^
/var/tmp/php_build/php_src/ext/openssl/xp_ssl.c:968:3: warning: 'TLSv1_1_server_method' is deprecated [-Wdeprecated-declarations]
   return is_client ? TLSv1_1_client_method() : TLSv1_1_server_method();
   ^~~~~~
In file included from /usr/local/include/openssl/e_os2.h:13:0,
                 from /usr/local/include/openssl/err.h:13,
                 from /var/tmp/php_build/php_src/ext/openssl/php_openssl.h:69,
                 from /var/tmp/php_build/php_src/ext/openssl/xp_ssl.c:32:
/usr/local/include/openssl/ssl.h:1859:1: note: declared here
 DEPRECATEDIN_1_1_0(__owur const SSL_METHOD *TLSv1_1_server_method(void))
 ^
/var/tmp/php_build/php_src/ext/openssl/xp_ssl.c:976:3: warning: 'TLSv1_2_client_method' is deprecated [-Wdeprecated-declarations]
   return is_client ? TLSv1_2_client_method() : TLSv1_2_server_method();
   ^~~~~~
In file included from /usr/local/include/openssl/e_os2.h:13:0,
                 from /usr/local/include/openssl/err.h:13,
                 from /var/tmp/php_build/php_src/ext/openssl/php_openssl.h:69,
                 from /var/tmp/php_build/php_src/ext/openssl/xp_ssl.c:32:
/usr/local/include/openssl/ssl.h:1866:1: note: declared here
 DEPRECATEDIN_1_1_0(__owur const SSL_METHOD *TLSv1_2_client_method(void))
 ^
/var/tmp/php_build/php_src/ext/openssl/xp_ssl.c:976:3: warning: 'TLSv1_2_server_method' is deprecated [-Wdeprecated-declarations]
   return is_client ? TLSv1_2_client_method() : TLSv1_2_server_method();
   ^~~~~~
In file included from /usr/local/include/openssl/e_os2.h:13:0,
                 from /usr/local/include/openssl/err.h:13,
                 from /var/tmp/php_build/php_src/ext/openssl/php_openssl.h:69,
                 from /var/tmp/php_build/php_src/ext/openssl/xp_ssl.c:32:
/usr/local/include/openssl/ssl.h:1865:1: note: declared here
 DEPRECATEDIN_1_1_0(__owur const SSL_METHOD *TLSv1_2_server_method(void))
 ^

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-10-28 11:40 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2018-10-28 11:40 UTC] cmb@php.net
These deprecated functions are no longer used as of PHP 7.3.0[1].
Since OpenSSL 1.1.1 is a long term release which is supposed to be
supported until 2013 at least[2], i.e. much longer than PHP
7.2.0[3], these compile time warnings are basically irrelevant.

[1] <https://github.com/php/php-src/pull/3317>
[2] <https://www.openssl.org/blog/blog/2018/09/11/release111/>
[3] <http://php.net/supported-versions.php>
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Nov 29 09:01:24 2020 UTC