php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77073 empty orgtable column mysql 8
Submitted: 2018-10-27 18:41 UTC Modified: 2018-10-27 18:44 UTC
From: dvorak at logbookie dot eu Assigned:
Status: Not a bug Package: MySQLi related
PHP Version: 7.2.11 OS: debian 9
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dvorak at logbookie dot eu
New email:
PHP Version: OS:

 

 [2018-10-27 18:41 UTC] dvorak at logbookie dot eu
Description:
------------
7.2.11-2+0~20181015120801.9+stretch~1.gbp8105e0
mysql 8.12

execute this query:
 SELECT `ST`.* FROM `information_schema`.`STATISTICS` `ST` WHERE `ST`.`TABLE_SCHEMA` = 'global' AND `ST`.`TABLE_NAME` = 'deploy' ORDER BY `ST`.`INDEX_NAME` ASC, `ST`.`SEQ_IN_INDEX` ASC

execute \mysqli_fetch_fields( $result );
orgtable field is empty

Test script:
---------------
<?php
$connection = mysqli_connect( '127.0.0.1', 'root' );

$mysqliResult = mysqli_query( $connection, " SELECT `ST`.* FROM `information_schema`.`STATISTICS` `ST` WHERE `ST`.`TABLE_SCHEMA` = 'global' AND `ST`.`TABLE_NAME` = 'deploy' ORDER BY `ST`.`INDEX_NAME` ASC, `ST`.`SEQ_IN_INDEX` ASC" );
var_dump( \mysqli_fetch_fields( $mysqliResult ) );

Expected result:
----------------
filled orgtable column

Actual result:
--------------
empty orgtable column

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-10-27 18:44 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2018-10-27 18:44 UTC] requinix@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

https://dev.mysql.com/doc/refman/8.0/en/statistics-table.html
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Oct 26 03:03:35 2021 UTC