php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77049 Wrong timezone 2018 for Brazil
Submitted: 2018-10-22 23:11 UTC Modified: 2018-10-23 08:59 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:1 of 2 (50.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: alysson at rxsaude dot com dot br Assigned: cmb (profile)
Status: Not a bug Package: timezonedb (PECL)
PHP Version: 7.1.23 OS: Debian
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
16 + 34 = ?
Subscribe to this entry?

 
 [2018-10-22 23:11 UTC] alysson at rxsaude dot com dot br
Description:
------------
The Brazilian DST for 2018 is scheduled to start at November 4, 2018 [1].
But it still think it starts on October 21. 

Affected versions:
- PHP 7.0.32
- PHP 7.1.23
- PHP 7.2.11

[1]: https://www.timeanddate.com/news/time/brazil-delays-dst-2018.html

Test script:
---------------
ini_set('date.timezone', 'UTC');
$cal = new IntlGregorianCalendar(2018, 9, 22, 12, 0, 0);

//echo IntlDateFormatter::formatObject($cal, 'Y-M-d h:mm:ss Z (z)')."\n";
//Output 2018-10-22 12:00:00 +0000 (UTC)

$cal->setTimeZone('America/Sao_Paulo');

echo IntlDateFormatter::formatObject($cal, 'Y-M-d h:mm:ss Z (z)')."\n";
//Output 2018-10-22 10:00:00 -0200 (BRST)
//Should output 2018-10-22 09:00:00 -0300 (BRT)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-10-23 03:56 UTC] a at b dot c dot de
See also #76969
 [2018-10-23 08:59 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2018-10-23 08:59 UTC] cmb@php.net
Indeed, a duplicate of bug #76969, and as such not a PHP bug.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Dec 12 21:01:26 2019 UTC