php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76988 Wrong spelling in time zone name
Submitted: 2018-10-09 16:50 UTC Modified: 2018-10-09 17:03 UTC
Votes:2
Avg. Score:3.0 ± 2.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: igor dot yavych at gmail dot com Assigned:
Status: Not a bug Package: Date/time related
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
 [2018-10-09 16:50 UTC] igor dot yavych at gmail dot com
Description:
------------
In PHP, regardless of its version, you get Ukraine's timezone with incorrect spelling of its capital city. Currently, you can retrieve it with Europe/Kiev which is incorrect spelling. Correct spelling would be Europe/Kyiv.

Kyiv is the right version as decided by UNCSGN (United Nations Conferences on the Standardization of Geographical Names) and UNGEGN (United Nations Group of Experts on Geographical Names)."Kiev" is in Russian.

Test script:
---------------
None

Expected result:
----------------
None

Actual result:
--------------
None

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-10-09 16:57 UTC] mega6382 at mega6382 dot me
This is not PHP specific, that is just what the timezone is called, please check https://en.wikipedia.org/wiki/List_of_tz_database_time_zones
 [2018-10-09 17:03 UTC] peehaa@php.net
-Status: Open +Status: Not a bug
 [2018-10-09 17:03 UTC] peehaa@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php
 [2018-10-09 17:11 UTC] igor dot yavych at gmail dot com
Hello, thank you, I've written to IANA regarding the situation.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Feb 24 07:01:28 2024 UTC