php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76933 Different behaviour with opcache on
Submitted: 2018-09-26 08:35 UTC Modified: 2018-09-26 08:51 UTC
From: alex dot a dot pott at gmail dot com Assigned:
Status: Closed Package: opcache
PHP Version: 7.3.0RC1 OS: OSX
Private report: No CVE-ID: None
 [2018-09-26 08:35 UTC] alex dot a dot pott at gmail dot com
Description:
------------
Turning on opcache causes tests to fail. We are seeing this with Drupal see https://www.drupal.org/project/drupal/issues/3001920.

Local testing sees a different bug than we're seeing on drupal.org and this potentially narrows it down to something occurring in symfony/yaml which is a bit easier to reproduce. See test script for instructions on how to.

Test script:
---------------
git clone https://github.com/symfony/symfony.git
cd symfony
composer install
php ./phpunit src/Symfony/Component/Yaml/

Running the tests with the following opcache on in CLI causes them to fail. This does not happen on PHP7.2.

My opcache settings:
opcache.enable=1
opcache.enable_cli=1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-09-26 08:38 UTC] nikic@php.net
This may be due to bug #76711, so the upcoming RC2 might resolve this.
 [2018-09-26 08:44 UTC] alex dot a dot pott at gmail dot com
Yep. Sorry for the noise it is totally a duplicate. Thanks.
 [2018-09-26 08:51 UTC] alex dot a dot pott at gmail dot com
-Status: Open +Status: Closed
 [2018-09-26 08:51 UTC] alex dot a dot pott at gmail dot com
Closing
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Apr 10 18:01:24 2021 UTC