php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7693 QUERY_STRING set in apache env, but not set in enviroment
Submitted: 2000-11-08 05:31 UTC Modified: 2000-12-07 12:06 UTC
From: jeremy at ispsystems dot com dot au Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.3pl1 OS: debian potato
Private report: No CVE-ID:
 [2000-11-08 05:31 UTC] jeremy at ispsystems dot com dot au
This is part of a PHP page for an accounting system. I added a phpinfo() call into the page, which shows the QUERY_STRING is not being set in the enviroment, but is set in the apache enviroment. I know that this generates the other errors on the page. We have a work around for the problem (set the QUERY_STRING manually), but thought we should let you know it exists. Problem only occurred when customers upgraded themselves to PHP4.0.3. Upgrading the the latest patch level didn't make the problem go away, unfortunately.

Account History - 
User Access denied. If you believe this to be incorrect please contact admin@idl.net.au PHP Version 4.0.3pl1 

System Linux merlin 2.2.17 #2 Wed Sep 6 21:21:58 CEST 2000 i586 unknown 
Build Date Oct 16 2000 
Configure Command '../configure' '--prefix=/usr' '--with-apxs=/usr/bin/apxs' '--with-regex=system' '--with-config-file-path=/etc/php4/apache' '--enable-calendar' '--with-db' '--without-dom' '--enable-filepro' '--enable-ftp' '--with-gettext' '--enable-sysvsem' '--enable-sysvshm' '--enable-track-vars' '--enable-trans-sid' '--disable-debug' '--disable-static' '--with-gd=shared' '--with-imap=shared' '--with-ldap=shared,/usr' '--with-mm' '--with-mhash=shared' '--with-mysql=shared,/usr' '--with-regex=system' '--with-pcre-regex=/usr' '--with-pgsql=shared,/usr' '--with-snmp=shared' '--enable-sockets' '--with-ttf' '--enable-freetype-4bit-antialias-hack' '--with-t1lib' '--with-xml=shared,/usr' '--with-yp' '--with-zlib' 
Server API Apache 
Virtual Directory Support disabled 
Configuration File (php.ini) Path /etc/php4/apache 
ZEND_DEBUG disabled 
Thread Safety disabled 

 This program makes use of the Zend scripting language engine:
Zend Engine v1.0.3, Copyright (c) 1998-2000 Zend Technologies

 




--------------------------------------------------------------------------------

PHP 4.0 Credits

--------------------------------------------------------------------------------

Configuration
PHP Core 
Directive Local Value Master Value 
allow_call_time_pass_reference
 On On 
arg_separator
 & & 
asp_tags
 Off Off 
auto_append_file
 no value no value 
auto_prepend_file
 no value no value 
browscap
 no value no value 
default_charset
 no value no value 
default_mimetype
 text/html text/html 
define_syslog_variables
 Off Off 
disable_functions
 no value no value 
display_errors
 On On 
display_startup_errors
 Off Off 
doc_root
 no value no value 
enable_dl
 On On 
error_append_string
 Off Off 
error_log
 no value no value 
error_prepend_string
 Off Off 
error_reporting
 2039 2039 
expose_php
 On On 
extension_dir
 /usr/lib/php4/apache /usr/lib/php4/apache 
file_uploads
 1 1 
gpc_order
 GPC GPC 
highlight.bg
 #FFFFFF #FFFFFF 
highlight.comment
 #FF8000 #FF8000 
highlight.default
 #0000BB #0000BB 
highlight.html
 #000000 #000000 
highlight.keyword
 #007700 #007700 
highlight.string
 #DD0000 #DD0000 
html_errors
 On On 
ignore_user_abort
 Off Off 
implicit_flush
 Off Off 
include_path
 .:/usr/lib/php4 .:/usr/lib/php4 
log_errors
 Off Off 
magic_quotes_gpc
 On On 
magic_quotes_runtime
 Off Off 
magic_quotes_sybase
 Off Off 
max_execution_time
 30 30 
open_basedir
 no value no value 
output_buffering
 Off Off 
post_max_size
 8M 8M 
precision
 14 14 
register_argc_argv
 On On 
register_globals
 On On 
safe_mode
 Off Off 
safe_mode_exec_dir
 no value no value 
sendmail_from
 me@localhost.com me@localhost.com 
sendmail_path
 /usr/sbin/sendmail -t -i  /usr/sbin/sendmail -t -i  
short_open_tag
 On On 
SMTP
 localhost localhost 
sql.safe_mode
 Off Off 
track_errors
 Off Off 
upload_max_filesize
 2M 2M 
upload_tmp_dir
 no value no value 
user_dir
 no value no value 
variables_order
 EGPCS EGPCS 
y2k_compliance
 Off Off 


mysql
MySQL Support enabled 
Active Persistent Links 0 
Active Links 1 
Client API version 3.22.30 
MYSQL_INCLUDE   
MYSQL_LFLAGS   
MYSQL_LIBS   

Directive Local Value Master Value 
mysql.allow_persistent
 On On 
mysql.default_host
 no value no value 
mysql.default_password
 no value no value 
mysql.default_port
 no value no value 
mysql.default_socket
 no value no value 
mysql.default_user
 no value no value 
mysql.max_links
 Unlimited Unlimited 
mysql.max_persistent
 Unlimited Unlimited 


imap
IMAP Support enabled 
IMAP c-Client Version 4.1 


zlib
ZLib Support enabled 
Compiled Version 1.1.3 
Linked Version 1.1.3 


standard
Regex Library System library enabled 
Dynamic Library Support enabled 
Path to sendmail /usr/sbin/sendmail -t -i  

Directive Local Value Master Value 
assert.active
 1 1 
assert.bail
 0 0 
assert.callback
 no value no value 
assert.quiet_eval
 0 0 
assert.warning
 1 1 
safe_mode_allowed_env_vars
 PHP_ PHP_ 
safe_mode_protected_env_vars
 LD_LIBRARY_PATH LD_LIBRARY_PATH 
session.use_trans_sid
 1 1 


sockets
sockets support enabled 


session
Session Support enabled 

Directive Local Value Master Value 
session.auto_start
 Off Off 
session.cache_expire
 180 180 
session.cache_limiter
 nocache nocache 
session.cookie_domain
 no value no value 
session.cookie_lifetime
 0 0 
session.cookie_path
 / / 
session.entropy_file
 no value no value 
session.entropy_length
 0 0 
session.gc_maxlifetime
 1440 1440 
session.gc_probability
 1 1 
session.name
 PHPSESSID PHPSESSID 
session.referer_check
 no value no value 
session.save_handler
 files files 
session.save_path
 /tmp /tmp 
session.serialize_handler
 php php 
session.use_cookies
 On On 


posix
Revision $Revision: 1.26 $ 


pcre
PCRE (Perl Compatible Regular Expressions) Support enabled 
PCRE Library Version 2.08 31-Aug-1999 


gettext
GNU GetText Support enabled 


ftp
FTP support enabled 


db
ndbm support enabled 


Calendar
Calendar support enabled 


apache
APACHE_INCLUDE   
APACHE_TARGET   
Apache Version Apache/1.3.9 
Apache Release 10309100 
Apache API Version 19990320 
Hostname:Port accsys2.wanet.com.au:80 
User/Group www-data(33)/33 
Max Requests Per Child: 30
Keep Alive: on
Max Per Connection: 100 
Timeouts Connection: 300
Keep-Alive: 15 
Server Root /etc/apache 
Loaded Modules mod_php4, mod_setenvif, mod_unique_id, mod_expires, mod_auth, mod_access, mod_rewrite, mod_alias, mod_userdir, mod_cgi, mod_dir, mod_autoindex, mod_status, mod_negotiation, mod_mime, mod_log_config, mod_macro, mod_so, http_core 


Apache Environment
Variable Value 
DOCUMENT_ROOT /usr/local/accsys/web/web 
HTTP_ACCEPT */* 
HTTP_ACCEPT_ENCODING gzip, deflate 
HTTP_ACCEPT_LANGUAGE en-au 
HTTP_CACHE_CONTROL max-stale=0 
HTTP_HOST accsys2.wanet.com.au 
HTTP_USER_AGENT Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0) 
PATH /bin:/usr/bin:/sbin:/usr/sbin 
REMOTE_ADDR 203.34.122.170 
REMOTE_PORT 50314 
SCRIPT_FILENAME /usr/local/accsys/web/web/dealer/user/uperoid.phtml 
SERVER_ADDR 202.6.125.51 
SERVER_ADMIN webmaster@cujo2 
SERVER_NAME accsys2.wanet.com.au 
SERVER_PORT 80 
SERVER_SIGNATURE   
SERVER_SOFTWARE Apache/1.3.9 (Unix) Debian/GNU PHP/4.0.3pl1 
UNIQUE_ID OgjS-coGfTIAAFpcfqU 
GATEWAY_INTERFACE CGI/1.1 
SERVER_PROTOCOL HTTP/1.0 
REQUEST_METHOD GET 
QUERY_STRING from=973008000&to=973656660&user_id=2635 
REQUEST_URI /dealer/user/uperoid.phtml?from=973008000&to=973656660&user_id=2635 
SCRIPT_NAME /dealer/user/uperoid.phtml 


HTTP Headers Information
HTTP Request Headers 
HTTP Request GET /dealer/user/uperoid.phtml?from=973008000&to=973656660&user_id=2635 HTTP/1.0 
Accept */* 
Accept-Encoding gzip, deflate 
Accept-Language en-au 
Authorization Basic d2FuZXQ6ODkydGVzdGljbGU5ODg= 
Cache-Control max-stale=0 
Host accsys2.wanet.com.au 
User-Agent Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0) 
HTTP Response Headers 
X-Powered-By PHP/4.0.3pl1 
Connection close 
Content-Type text/html; charset=iso-8859-1 


Additional Modules
sysvshm 
sysvsem 
filepro 
Session MM 


Environment
Variable Value 
PWD /root 
HZ 100 
HOSTNAME cujo2 
USER root 
MACHTYPE i386-pc-linux-gnu 
MAIL /var/spool/mail/root 
LANG C 
LOGNAME root 
SHLVL 4 
SHELL /bin/bash 
HOSTTYPE i386 
OSTYPE linux-gnu 
TERM vt100 
HOME /root 
PATH /bin:/usr/bin:/sbin:/usr/sbin 
_ /usr/sbin/apache 
REQUEST_METHOD GET 
QUERY_STRING   
REMOTE_USER wanet 
SERVER_PORT 80 
GATEWAY_INTERFACE CGI/1.1 
HTTP_USER_AGENT Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0) 
REMOTE_PORT 50314 
HTTP_HOST accsys2.wanet.com.au 
SCRIPT_FILENAME /usr/local/accsys/web/web/dealer/user/uperoid.phtml 
HTTP_CONNECTION   
UNIQUE_ID OgjS-coGfTIAAFpcfqU 
SERVER_SIGNATURE   
SERVER_ADMIN webmaster@cujo2 
SCRIPT_NAME /dealer/user/uperoid.phtml 
REMOTE_ADDR 203.34.122.170 
SERVER_SOFTWARE Apache/1.3.9 (Unix) Debian/GNU PHP/4.0.3pl1 
SERVER_NAME accsys2.wanet.com.au 
SERVER_PROTOCOL HTTP/1.0 
HTTP_ACCEPT */* 
REQUEST_URI /dealer/user/uperoid.phtml?from=973008000&to=973656660&user_id=2635 
DOCUMENT_ROOT /usr/local/accsys/web/web 
HTTP_ACCEPT_LANGUAGE en-au 
HTTP_ACCEPT_CHARSET   


PHP Variables
Variable Value 
PHP_SELF /dealer/user/uperoid.phtml 
PHP_AUTH_USER wanet 
PHP_AUTH_PW 892testicle988 
HTTP_GET_VARS["from"] 973008000 
HTTP_GET_VARS["to"] 973656660 
HTTP_GET_VARS["user_id"] 2635 
HTTP_SERVER_VARS["DOCUMENT_ROOT"] /usr/local/accsys/web/web 
HTTP_SERVER_VARS["HTTP_ACCEPT"] */* 
HTTP_SERVER_VARS["HTTP_ACCEPT_ENCODING"] gzip, deflate 
HTTP_SERVER_VARS["HTTP_ACCEPT_LANGUAGE"] en-au 
HTTP_SERVER_VARS["HTTP_CACHE_CONTROL"] max-stale=0 
HTTP_SERVER_VARS["HTTP_HOST"] accsys2.wanet.com.au 
HTTP_SERVER_VARS["HTTP_USER_AGENT"] Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0) 
HTTP_SERVER_VARS["PATH"] /bin:/usr/bin:/sbin:/usr/sbin 
HTTP_SERVER_VARS["REMOTE_ADDR"] 203.34.122.170 
HTTP_SERVER_VARS["REMOTE_PORT"] 50314 
HTTP_SERVER_VARS["SCRIPT_FILENAME"] /usr/local/accsys/web/web/dealer/user/uperoid.phtml 
HTTP_SERVER_VARS["SERVER_ADDR"] 202.6.125.51 
HTTP_SERVER_VARS["SERVER_ADMIN"] webmaster@cujo2 
HTTP_SERVER_VARS["SERVER_NAME"] accsys2.wanet.com.au 
HTTP_SERVER_VARS["SERVER_PORT"] 80 
HTTP_SERVER_VARS["SERVER_SIGNATURE"]  
HTTP_SERVER_VARS["SERVER_SOFTWARE"] Apache/1.3.9 (Unix) Debian/GNU PHP/4.0.3pl1 
HTTP_SERVER_VARS["UNIQUE_ID"] OgjS-coGfTIAAFpcfqU 
HTTP_SERVER_VARS["GATEWAY_INTERFACE"] CGI/1.1 
HTTP_SERVER_VARS["SERVER_PROTOCOL"] HTTP/1.0 
HTTP_SERVER_VARS["REQUEST_METHOD"] GET 
HTTP_SERVER_VARS["QUERY_STRING"] from=973008000&to=973656660&user_id=2635 
HTTP_SERVER_VARS["REQUEST_URI"] /dealer/user/uperoid.phtml?from=973008000&to=973656660&user_id=2635 
HTTP_SERVER_VARS["SCRIPT_NAME"] /dealer/user/uperoid.phtml 
HTTP_SERVER_VARS["PATH_TRANSLATED"] /usr/local/accsys/web/web/dealer/user/uperoid.phtml 
HTTP_SERVER_VARS["PHP_SELF"] /dealer/user/uperoid.phtml 
HTTP_SERVER_VARS["argv"] Array
(
    [0] => from=973008000&to=973656660&user_id=2635
)

 
HTTP_SERVER_VARS["argc"] 1 
HTTP_SERVER_VARS["PHP_AUTH_USER"] wanet 
HTTP_SERVER_VARS["PHP_AUTH_PW"] 892testicle988 
HTTP_ENV_VARS["PWD"] /root 
HTTP_ENV_VARS["HZ"] 100 
HTTP_ENV_VARS["HOSTNAME"] cujo2 
HTTP_ENV_VARS["USER"] root 
HTTP_ENV_VARS["MACHTYPE"] i386-pc-linux-gnu 
HTTP_ENV_VARS["MAIL"] /var/spool/mail/root 
HTTP_ENV_VARS["LANG"] C 
HTTP_ENV_VARS["LOGNAME"] root 
HTTP_ENV_VARS["SHLVL"] 4 
HTTP_ENV_VARS["SHELL"] /bin/bash 
HTTP_ENV_VARS["HOSTTYPE"] i386 
HTTP_ENV_VARS["OSTYPE"] linux-gnu 
HTTP_ENV_VARS["TERM"] vt100 
HTTP_ENV_VARS["HOME"] /root 
HTTP_ENV_VARS["PATH"] /bin:/usr/bin:/sbin:/usr/sbin 
HTTP_ENV_VARS["_"] /usr/sbin/apache 


PHP License
This program is free software; you can redistribute it and/or modify it under the terms of the PHP License as published by the PHP Group and included in the distribution in the file: LICENSE 

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. 

If you did not receive a copy of the PHP license, or have any questions about PHP licensing, please contact license@php.net. 
 

 
Date Logged In Date Logged Out Online (min)
 Cost
 Balance
 
Incomming Data (Mb)
 Outgoing Data (Mb)
 Data Cost
 
User Access denied. If you believe this to be incorrect please contact admin@idl.net.au  


User Access denied. If you believe this to be incorrect please contact admin@idl.net.au 


If any of the above details appear incorrect, out of order or just strange please contact our helpdesk A.S.A.P. By either phone on 02 49614356 or e-mail at helpdesk@idl.net.au 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-08 20:25 UTC] derick@php.net
I could not reproduce this with the latest CVS version, can you check if it works for you?
You can also use a snapshot from snaps.php.net
 [2000-12-07 12:06 UTC] sniper@php.net
No feedback.
Reopen, if this still happens when using latest snapshot
from http://snaps.php.net/

--Jani
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 04:01:55 2014 UTC