php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76907 Version 2.4.0 won't install in docker
Submitted: 2018-09-19 21:13 UTC Modified: 2018-12-05 15:46 UTC
From: colin dot viebrock at priceline dot com Assigned: cmb (profile)
Status: Duplicate Package: solr (PECL)
PHP Version: 7.2.10 OS: Debian
Private report: No CVE-ID: None
 [2018-09-19 21:13 UTC] colin dot viebrock at priceline dot com
Description:
------------
It's reported in a few places that `pecl install solar-2.4.0` doesn't work with PHP 7.2, e.g.

* https://groups.google.com/forum/#!topic/php-solr/ZxP1WHkaPXY

It would be helpful if a new version of the package could be tagged so that we aren't forced to compile from source when setting up, for instance, a Docker image.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-09-20 08:46 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2018-09-20 08:46 UTC] cmb@php.net
Duplicate of bug #75631.
 [2018-12-04 20:22 UTC] glen at pld-linux dot org
cmb, are you able to make 2.4.0 and 2.4.1 releases?

see https://bugs.php.net/bug.php?id=75631 comments...
 [2018-12-05 15:46 UTC] colin dot viebrock at priceline dot com
I can clone the php/pecl-search_engine-solr repo, checkout that commit (744e329), and successfully do a phpize/configure/make.

It seems the real issue is just adding release tags to that repo, as the related bug suggests.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Apr 23 12:01:25 2019 UTC