php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76819 doc.php.net is down
Submitted: 2018-08-30 14:07 UTC Modified: 2019-01-12 15:53 UTC
Votes:4
Avg. Score:5.0 ± 0.0
Reproduced:3 of 3 (100.0%)
Same Version:1 (33.3%)
Same OS:1 (33.3%)
From: aljosha dot papsch at vinexus dot eu Assigned: cmb (profile)
Status: Closed Package: Systems problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2018-08-30 14:07 UTC] aljosha dot papsch at vinexus dot eu
Description:
------------
The request for http://doc.php.net/downloads/json/php_manual_en.json is timing out. I didn't find a new URL. At least php-extras[0] depends on it to show function parameters.

[0] https://github.com/arnested/php-extras/issues/new

Test script:
---------------
curl -m 5 http://doc.php.net/downloads/json/php_manual_en.json

Expected result:
----------------
The webserver should respond with the file in a reasonable time.

Actual result:
--------------
Request timeout.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-08-30 14:14 UTC] cmb@php.net
-Summary: Request for php_manual_en.json times out +Summary: doc.php.net is down -Status: Open +Status: Verified -Package: Website problem +Package: Systems problem
 [2018-08-30 14:14 UTC] cmb@php.net
Actually, doc.php.net is down since yesterday.
 [2018-08-31 10:26 UTC] lk at man-da dot de
Hi,

this of course also affects the PEAR-Channel reffering to doc.php.net


# pear list-channels
Registered Channels:
====================
Channel      Alias   Summary
doc.php.net  phpdocs PHP Documentation team
pear.php.net pear    PHP Extension and Application
                     Repository
pecl.php.net pecl    PHP Extension Community Library
__uri        __uri   Pseudo-channel for static packages

# pear channel-update doc.php.net
Updating channel "doc.php.net"
Channel "doc.php.net" is not responding over http://, failed with message: File http://doc.php.net:80/channel.xml not valid (redirected but no location)
Trying channel "doc.php.net" over https:// instead
Cannot retrieve channel.xml for channel "doc.php.net" (Connection to `ssl://doc.php.net:443' failed: Connection refused)

Has anyone looked at this, yet? ;-)

Kind regards
   Lars
 [2018-08-31 10:35 UTC] lk at man-da dot de
Sorry, would suggest Christoph did and this is a bigger issue, when also reading the addresses. ;-)
 [2018-08-31 13:27 UTC] rasmus@php.net
It isn't one of the machines I have access to, but ssh isn't responding anyway, so I have sent a request to EUKHost to reboot it.
 [2018-09-05 08:02 UTC] xyfantis at gmail dot com
Description:
------------
The request for http://doc.php.net/downloads/json/php_manual_en.json is timing out.

[0] https://github.com/arnested/php-extras/issues/new

Test script:
---------------
curl -m 5 http://doc.php.net/downloads/json/php_manual_en.json

Expected result:
----------------
The webserver should respond with the file in a reasonable time.

Actual result:
--------------
curl: (28) Operation timed out after 5000 milliseconds with 0 bytes received.
 [2018-09-15 10:53 UTC] cmb@php.net
-Status: Verified +Status: Closed -Assigned To: +Assigned To: cmb
 [2018-09-15 10:53 UTC] cmb@php.net
This appears to be resolved.
 [2019-01-08 15:15 UTC] spengilley at gmail dot com
I'm having the same problem via Pear today

Channel "doc.php.net" is not responding
 [2019-01-09 17:37 UTC] cmb@php.net
-Status: Closed +Status: Re-Opened -Assigned To: cmb +Assigned To:
 [2019-01-09 17:37 UTC] cmb@php.net
I can confirm that doc.php.net and docs.php.net are down again since yesterday.
 [2019-01-12 15:53 UTC] cmb@php.net
-Status: Re-Opened +Status: Closed -Assigned To: +Assigned To: cmb
 [2019-01-12 15:53 UTC] cmb@php.net
This has apparently been fixed in the meantime.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Mar 02 11:01:23 2021 UTC