php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76817 Can't establish a connection to MySQL after upgrading from 7.2.9 to 7.3.0RC1
Submitted: 2018-08-30 09:24 UTC Modified: 2018-09-17 06:06 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: ildar dot aim at gmail dot com Assigned: mysql (profile)
Status: Not a bug Package: MySQLi related
PHP Version: 7.3.0RC1 OS: archlinux 64
Private report: No CVE-ID: None
 [2018-08-30 09:24 UTC] ildar dot aim at gmail dot com
Description:
------------
The script is same as in 
https://bugs.php.net/bug.php?id=76651

| default_authentication_plugin | mysql_native_password |

mysql  Ver 8.0.12 for Linux on x86_64 (MySQL Community Server (GPL))


Test script:
---------------
Should you add beta3 in the 'PHP version:' select box ?

Actual result:
--------------
Warning: mysqli_connect(): (HY000/2002): No such file or directory in /home/aim/public_html/p.php on line 10
Error: Unable to connect to MySQL. Debugging errno: 2002 Debugging error: No such file or directory 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-08-30 09:26 UTC] ildar dot aim at gmail dot com
-Package: MySQL related +Package: MySQLi related -PHP Version: 7.3.0beta2 +PHP Version: 7.3.0beta3
 [2018-08-30 09:26 UTC] ildar dot aim at gmail dot com
a code like 
$link = mysqli_connect($host, $sql_user, $sql_password);
is used.
 [2018-08-30 16:39 UTC] cmb@php.net
-Assigned To: +Assigned To: mysql
 [2018-09-07 15:27 UTC] ildar dot aim at gmail dot com
The same problem is on beta1 and beta2 versions.
 [2018-09-12 04:16 UTC] ildar dot aim at gmail dot com
-Summary: Can't establish a connection to MySQL after upgrading from 7.2.9 to 7.3.0beta3 +Summary: Can't establish a connection to MySQL after upgrading from 7.2.9 to 7.3.0RC1 -PHP Version: 7.3.0beta3 +PHP Version: 7.3.0RC1
 [2018-09-12 04:16 UTC] ildar dot aim at gmail dot com
I have changed the target version from 
7.3.0beta3 to 7.3.0RC1

Just checked it
 [2018-09-14 18:57 UTC] no at mail dot here
This bug is not resolved in PHP 7.2.10 (cli) (built: Sep 13 2018 00:47:25) ( NTS MSVC15 (Visual C++ 2017) x64 ) either. See new comment in https://bugs.php.net/bug.php?id=76651.
 [2018-09-16 06:48 UTC] nikic@php.net
This looks like a different issue from bug #76651, because that one also affects PHP 7.2.9 (which here is said to work correctly).

To check for the obvious first, are both PHP versions (PHP 7.2.9 and PHP 7.3.0RC1) using mysqlnd (and not libmysql)?
 [2018-09-16 09:29 UTC] no at mail dot here
Maybe I misread this bug. If so, just scratch my previous comment.
 [2018-09-17 05:58 UTC] ildar dot aim at gmail dot com
-Status: Assigned +Status: Closed
 [2018-09-17 05:58 UTC] ildar dot aim at gmail dot com
My bad 

-mysqli.default_socket => no value => no value
+mysqli.default_socket => /run/mysqld/mysqld.sock => /run/mysqld/mysqld.sock

helps me.

Sorry for that.
 [2018-09-17 06:06 UTC] nikic@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Aug 18 04:01:28 2019 UTC