php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7679 multipart/form-data (upload) form method broken
Submitted: 2000-11-07 14:40 UTC Modified: 2000-12-15 19:59 UTC
From: jamie at trewtech dot copm Assigned:
Status: Closed Package: HTTP related
PHP Version: 4.0.3pl1 OS: Red Hat Linux 6.2
Private report: No CVE-ID: None
 [2000-11-07 14:40 UTC] jamie at trewtech dot copm
Problem occurs with Apache 1.3.14 + Mod_SSL 2.7.1 + mod_perl 1.24_01 + mod_php 4.0.3pl1

Problem occurs with Apache 1.3.12 + mod_ssl 2.6.5 + mod_perl 1.24_01 + mod_php 4.03pl1

Problem does not occur with Apache 1.3.12 + mod_ssl 2.6.5 + mod_perl 1.24_01 + mod_php 4.02

History:

I recently went from Apache 1.3.12 + PHP 4.0.2 to Apache 1.3.14 + 4.0.3pl1.

After upgrading, my web upload forms were broken.  The script would die after less than 15 seconds or so when uploading a big file, and a new page would not be loaded (e.g. no error was reported to the web client, it just stopped and reloaded the old form).  Small files would sometimes still work.  Apache reported:

[Fri Nov  3 11:17:24 2000] [error] [client 192.168.1.3] Invalid method in request -----------------------------7d03b626abc

I initially assumed this was an Apache 1.3.14 error, so I unhappily rebuilt Apache 1.3.12 with PHP 4.0.3pl1.  However, after this, the problem still occurred.

So I rebuilt again with my previous configuration (4.0.2) and everything worked again.  So I can only assume that there is a problem with the new PHP version.  The only thing I've yet to try (for lack of time) is PHP 4.0.2 on Apache 1.3.14 which -- if it works -- would confirm that the problem is with PHP rather than Apache.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-12 11:55 UTC] jmoore@php.net
---feedback from user -----------
> File uploads of any significant size don't work (script dies 
> after a little 
> while with no error reported by script). Bug report at:
> 
> http://bugs.php.net/bugs.php?id=7679
> 
> I have now tested Apache 1.3.14 + php4.0.2 and uploading works fine.
> Does not work with Apache 1.3.12 + php4.0.3pl1 or 1.3.14 + php4.0.3pl1
> 
> My httpd.conf includes:
> 
> php_flag file_uploads on
> php_value post_max_size 99999999
> php_value upload_max_filesize 99999999
> 
> -- Jamie
-------------------------------------------------
try making memory_limit larger too.

James
 [2000-12-15 19:59 UTC] sniper@php.net
No feedback. Works for me just fine (latest CVS and 4.0.4RC6)

--Jani
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Apr 18 22:01:25 2019 UTC