php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7673 PHP crashes when odbc_result is given a result ID as its second parameter
Submitted: 2000-11-07 06:50 UTC Modified: 2001-03-06 22:04 UTC
From: jacobm at rice dot edu Assigned: kalowsky (profile)
Status: Not a bug Package: ODBC related
PHP Version: 4.0.3pl1 OS: Windows '98
Private report: No CVE-ID: None
 [2000-11-07 06:50 UTC] jacobm at rice dot edu
On my test machine (a Windows 98 box running the precompiled Win32 PHP 4.0.3pl1 binary as a CGI program on top of Apache 1.3.12), the following (admittedly bizarre) code will crash PHP:

$db = odbc_connect("db1","","");
$result = odbc_exec("SELECT * FROM table1");
while ($odbc_fetch_row($result)) {
  print odbc_result($result, $result);
}

It will crash it no matter what resource ID PHP has assigned to $result, and even if odbc_result's arguments 1 and 2 point to different result sets, even from different databases.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-14 08:23 UTC] kalowsky@php.net
and finally the last of which I'll be looking at this time around.  the question to start off with, does this continue on PHP4.0.4pl1?
 [2001-03-06 22:04 UTC] kalowsky@php.net
your script is faulty.  please correct your script and 
check report back. 

marking this as bogus as i am unable to reproduce this 
...
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Dec 03 10:01:24 2020 UTC