php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76709 Minimal required zlib library is 1.2.0.4
Submitted: 2018-08-06 07:22 UTC Modified: 2018-08-06 10:12 UTC
From: petk@php.net Assigned: petk (profile)
Status: Closed Package: Zlib related
PHP Version: 7.1.20 OS:
Private report: No CVE-ID: None
 [2018-08-06 07:22 UTC] petk@php.net
Description:
------------
Documentation for the zlib says that minimal required version for zlib is 1.0.9:
http://php.net/manual/en/zlib.requirements.php

However there was an update of the zlib extension API and it now requires at least 1.2.0.4 version of zlib system library. The minimal required version is also reported in the 'configure --help' output. This affects active PHP 7.1+ versions.

Test script:
---------------
./buildconf
./configure --help | grep zlib

Expected result:
----------------
--with-zlib=DIR         Include ZLIB support (requires zlib >= 1.2.0.4)

Actual result:
--------------
--with-zlib=DIR         Include ZLIB support (requires zlib >= 1.0.9)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-08-06 07:36 UTC] requinix@php.net
-Type: Documentation Problem +Type: Bug
 [2018-08-06 07:36 UTC] requinix@php.net
Seems like it happened 8 years ago with PHP 5.4?
https://github.com/php/php-src/commit/11d24c1593d6617f73d3f290617bd8994182f4dc#diff-e6a0538da2ce7ab6c67ecf482c981f50

The docs need updating, but so does the .m4's description of --with-zlib.
 [2018-08-06 07:43 UTC] petk@php.net
Automatic comment on behalf of peterkokot@gmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=a3e3d914edffc3128b67ba73ca7dc85c07aede43
Log: Fix bug #76709: Minimal required zlib library is 1.2.0.4
 [2018-08-06 07:43 UTC] petk@php.net
-Status: Open +Status: Closed
 [2018-08-06 07:45 UTC] petk@php.net
-Status: Closed +Status: Re-Opened
 [2018-08-06 07:47 UTC] petk@php.net
Thanks, I've updated the config0.m4 file via the above patch. I'm also reopening this one since the docs need to be updated as well. I guess, this is best to be reported separately in such cases.
 [2018-08-06 07:47 UTC] petk@php.net
-Assigned To: +Assigned To: petk
 [2018-08-06 10:12 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&revision=345437
Log: Fix #76709: Minimal required zlib library is 1.2.0.4
 [2018-08-06 10:12 UTC] cmb@php.net
-Status: Re-Opened +Status: Closed
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Wed Sep 26 10:01:25 2018 UTC