php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76706 mbstring.http_output_conv_mimetypes is ignored
Submitted: 2018-08-04 20:59 UTC Modified: 2018-08-04 20:59 UTC
From: cmb@php.net Assigned: cmb (profile)
Status: Closed Package: mbstring related
PHP Version: 7.3.0beta1 OS: *
Private report: No CVE-ID: None
 [2018-08-04 20:59 UTC] cmb@php.net
Description:
------------
If mbstring is built without mbregex support,
mbstring.http_output_conv_mimetypes is basically ignored.

The problem is that the return value of the PCRE fallback
implementation of _php_mb_match_regex()[1] is not “normalized” to
return a truthy value in case of match, and a falsey value
otherwise.

[1] <https://github.com/php/php-src/blob/php-7.3.0beta1/ext/mbstring/mbstring.c#L1071-L1074>

Test script:
---------------
ext/mbstring/tests/mb_output_handler_pattern-04.phpt

Expected result:
----------------
Test succeeds

Actual result:
--------------
Test fails

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-08-04 20:59 UTC] cmb@php.net
-Assigned To: +Assigned To: cmb
 [2018-08-04 21:35 UTC] cmb@php.net
Automatic comment on behalf of cmbecker69@gmx.de
Revision: http://git.php.net/?p=php-src.git;a=commit;h=70ecb6e50b983419f6a2d5e028f9779354047ec1
Log: Fix #76706: mbstring.http_output_conv_mimetypes is ignored
 [2018-08-04 21:35 UTC] cmb@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Thu Dec 13 23:01:24 2018 UTC