php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #76646 [DE] DOMDocument::createElement untranslated
Submitted: 2018-07-19 14:21 UTC Modified: 2018-07-21 12:59 UTC
From: henry at v1b dot es Assigned: cmb (profile)
Status: Not a bug Package: Translation problem
PHP Version: 7.3.0alpha4 OS: php.net
Private report: No CVE-ID: None
 [2018-07-19 14:21 UTC] henry at v1b dot es
Description:
------------
When German is selected english and german sentences and headlines are completely mixed

---
From manual page: http://www.php.net/domdocument.createelement
---
 seen before: Bug #72118: Not respecting accept language header

but still happening and makes content a lot harder to understand


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-07-19 14:50 UTC] requinix@php.net
-Summary: language fails +Summary: [DE] DOMDocument::createElement untranslated -Status: Open +Status: Verified -Package: *General Issues +Package: Translation problem
 [2018-07-19 14:50 UTC] requinix@php.net
That page is simply in need of translation.

You see mixed English and German because the page, which is written in XML, currently says
  This function creates a new instance of class <classname>DOMElement</classname>. &dom.node.inserted;

The first sentence is not translated and is a copy of the original English text. However the message that gets inserted using &dom.node.inserted *is* translated and so appears in German.
 [2018-07-21 12:59 UTC] cmb@php.net
-Status: Verified +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2018-07-21 12:59 UTC] cmb@php.net
There are presently 10,486 untranslated files in the German
translation[1], and the primary focus is on keeping existing
translations up-to-date, and to fix bugs in existing translations.

If you want a new translation, please provide a patch via
<https://edit.php.net/> (and make sure to translate the full page;
otherwise the patch will likely be rejected).

Anyhow, I don't consider this untranslated page a bug, and
changing to feature request wouldn't be helpful, since
untranslated pages are already tracked, so I'm closing this ticket
as not a bug.

[1] <http://doc.php.net/revcheck.php?p=graph&lang=de>
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Apr 18 06:01:23 2021 UTC