php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76633 oci_connect have different behaviour between php-fpm and php-cli
Submitted: 2018-07-16 12:47 UTC Modified: 2018-12-09 01:55 UTC
From: maxander dot game at gmail dot com Assigned:
Status: Not a bug Package: OCI8 related
PHP Version: 7.2.7 OS: CentOS Linux release 7.3.1611
Private report: No CVE-ID: None
 [2018-07-16 12:47 UTC] maxander dot game at gmail dot com
Description:
------------
oci_connect can connect to the OID to resolve the database adress when launched from php command line.
But oci_connect throws this exeption : "ORA-12154: TNS:could not resolve the connect identifier specified" when launched from my web application. (php-fpm).

Both fpm and cli have the same env variables and the same config.

Test script:
---------------
$conn = oci_connect('USERNAME', 'PASSW', 'OID_BDNAME');
//Where OID_BDNAME is the database name in OID. 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-07-16 21:16 UTC] cmb@php.net
-Package: PDO OCI +Package: OCI8 related
 [2018-12-09 01:55 UTC] sixd@php.net
-Status: Open +Status: Not a bug
 [2018-12-09 01:55 UTC] sixd@php.net
This sounds like a misconfiguration with setting the environment.  It should be followed up in a discussion forum first.  There's no immediate indication this is a bug.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Dec 16 09:01:26 2018 UTC