php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7662 mysql_connect() failure
Submitted: 2000-11-06 09:17 UTC Modified: 2002-06-16 08:22 UTC
From: mail at thomas-schuering dot de Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 3.0.17 OS: Win9x,NT,Win2K
Private report: No CVE-ID: None
 [2000-11-06 09:17 UTC] mail at thomas-schuering dot de
As some others I got some "Fatal error: Call to unsupported or undefined function mysql_connect() in
f:\html\test.php3 on line ..."

First I thought of a bug in PHP - then I took the time to get the mysql-3.23.27-beta sources and php-3.0.17 and gave it a try.

At the point I compiled php3_mysql.dll to it complained about "unresolved external: mysql_change_user". 

The appropiate entry in libmysql.def (project libmysql) was missing. I added it, repeated all necessary steps and created php3_mysql once again: NOW the linking was succesfull and guess what: the new php3_mysql.dll works!! (No more fatal error.)

Looks like the libmysql.lib and / or libmysql in the win32build.zip package doesn't fit.

Hope it help's.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-16 08:22 UTC] sander@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately, PHP 3 is no longer supported. Please download
the latest version of PHP 4 from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 02:03:13 2021 UTC