php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76572 natsort dash order error
Submitted: 2018-07-03 11:27 UTC Modified: 2018-07-03 11:42 UTC
From: volodymyrbas at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: Arrays related
PHP Version: 7.2.7 OS: Ubuntu 16.04
Private report: No CVE-ID: None
 [2018-07-03 11:27 UTC] volodymyrbas at gmail dot com
Description:
------------
nutsort function does not order strings with dash charater in proper order.

Test script:
---------------
<?php

$arr = [
  'Saint-Prex',
  'Saint Prex',
  'Saint Genis Pouilly',
];

natsort($arr);

print_r($arr);


Expected result:
----------------
Array
(
    [0] => Saint Genis Pouilly
    [2] => Saint Prex
    [1] => Saint-Prex
)


Actual result:
--------------
Array
(
    [0] => Saint-Prex
    [2] => Saint Genis Pouilly
    [1] => Saint Prex
)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-07-03 11:42 UTC] cmb@php.net
-Summary: nutsort dash order error +Summary: natsort dash order error -Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2018-07-03 11:42 UTC] cmb@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

natcasesort() is about alphanumeric strings; hyphens and underscores,
for instance, are not alphanumeric characters, though.  Use usort()
with an appropriate user defined comparison function, if you need it.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Apr 10 19:01:24 2020 UTC