php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76544 header() encodes mix of chinese and latin characters
Submitted: 2018-06-29 08:21 UTC Modified: 2018-06-29 08:33 UTC
From: sr at contreforme dot ch Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 7.1.19 OS:
Private report: No CVE-ID: None
 [2018-06-29 08:21 UTC] sr at contreforme dot ch
Description:
------------
Consider the following :
header("Refresh:0;url=https://xyzsite.com/content/中文");
header("Location:https://xyzsite.com/content/中文");

The "Refresh" will lead to "https://xyzsite.com/content/中文" when the "Location" will lead to correct URL.

Any idea why ?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-06-29 08:33 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2018-06-29 08:33 UTC] requinix@php.net
You have a character encoding problem somewhere.

And Refresh is a non-standard header. Don't use it.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Thu Nov 15 05:01:25 2018 UTC