php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76517 --with-gettext= causes configure to misjudges there is no getcwd
Submitted: 2018-06-22 05:50 UTC Modified: 2018-08-05 18:46 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: manabu dot matsui at gmail dot com Assigned: petk (profile)
Status: Closed Package: *Compile Issues
PHP Version: 7.2.7 OS: MacOS 10.13.5
Private report: No CVE-ID: None
 [2018-06-22 05:50 UTC] manabu dot matsui at gmail dot com
Description:
------------
Configure misjudges that there is no getcwd if --with-gettext=/usr/local/opt/gettext is specified. (gettext is installed by homebrew)

command to run configure:
./configure --disable-all --with-gettext=/usr/local/opt/gettext

output of configure:
...
checking for getcwd... no
...

in config.log:
configure:78929: checking for getcwd
configure:78929: cc -o conftest -g -O2 -fvisibility=hidden  -no-cpp-precomp  conftest.c -lintl -lm  >&5
ld: library not found for -lintl
clang: error: linker command failed with exit code 1 (use -v to see invocation)
configure:78929: $? = 1
configure: failed program was:
...


Since libintl.a is included in gettext, I think that either one is necessary.

* Remove the -lintl option
* Indicate the location of the intl library with the -L option


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-07-13 00:20 UTC] shinji dot igarashi at gmail dot com
https://github.com/php/php-src/pull/3381

This PR fixes the problem.
 [2018-08-05 18:46 UTC] petk@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: petk
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Wed Sep 26 10:01:25 2018 UTC