php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76515 if you multiply 1.9 by 3 and if you ta subtract the same the result is not zero
Submitted: 2018-06-22 02:34 UTC Modified: 2018-06-22 02:35 UTC
From: manuel dot cs dot hr at gmail dot com Assigned:
Status: Not a bug Package: Math related
PHP Version: 7.0Git-2018-06-22 (Git) OS: Linux
Private report: No CVE-ID: None
 [2018-06-22 02:34 UTC] manuel dot cs dot hr at gmail dot com
Description:
------------
if you multiply 1.9 by 3 the result is 5.7
and if you ta subtract the result 5.7 the answer is not zero

Test script:
---------------
<?php
$qty = 3;
$val1 = 1.9;
$discount = 5.7;

$items_ = $val1 * $qty ;

$result = $items_ - $discount;

var_dump($result);


?>

Expected result:
----------------
$result = 0;


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-06-22 02:35 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2018-06-22 02:35 UTC] requinix@php.net
Floating point values have a limited precision. Hence a value might 
not have the same string representation after any processing. That also
includes writing a floating point value in your script and directly 
printing it without any mathematical operations.

If you would like to know more about "floats" and what IEEE
754 is, read this:
http://www.floating-point-gui.de/

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Feb 20 11:01:24 2020 UTC