php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76483 PHP 7.3.0alpha1 cannot be compiled with system liblzip
Submitted: 2018-06-15 14:35 UTC Modified: 2019-03-20 07:59 UTC
From: pa at yourserveradmin dot com Assigned: cmb (profile)
Status: Not a bug Package: Zip Related
PHP Version: 7.3.0alpha1 OS: CentOS
Private report: No CVE-ID: None
 [2018-06-15 14:35 UTC] pa at yourserveradmin dot com
Description:
------------
Configuration script expects libzip version >= 0.11 which is not available for RHEL / CentOS releases which continue using 0.9 and 0.10 versions accordingly.

Just try to run "configure" command with "--with-libzip" flag (should be enabled by default) on RHEL / CentOS versions 6 or 7 and see the error.

Actual result:
--------------
checking libzip... yes
checking for the location of zlib... /usr
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for libzip... configure: error: system libzip must be upgraded to version >= 0.11

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-06-15 14:48 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2018-06-15 14:48 UTC] cmb@php.net
PHP 7.3.0alpha1 ships with libip 1.1.2.  Use --enable-zip
without --with-libzip to use this.
 [2018-06-15 14:48 UTC] pa at yourserveradmin dot com
-Status: Not a bug +Status: Open -Package: *Configuration Issues +Package: Zip Related
 [2018-06-15 14:48 UTC] pa at yourserveradmin dot com
Updated package to Zip Related.
 [2018-06-15 14:49 UTC] pa at yourserveradmin dot com
Thanks a lot, will try do this right now.
 [2018-06-15 14:49 UTC] cmb@php.net
-Status: Open +Status: Not a bug
 [2018-06-15 14:49 UTC] cmb@php.net
Seems we got in each other's way.
 [2018-06-15 15:39 UTC] pa at yourserveradmin dot com
Thanks! Combination from "--enable-zip" and "--without-libzip" flags solved my issue.
 [2018-06-15 16:28 UTC] spam2 at rhsoft dot net
and how is that a bug? either use a recent OS, compile your own version or just stick with the bundled stuff

honestly: why do you use CentOS at all when you want the latest shit? that's not what LTS distributons are for
 [2018-10-08 02:47 UTC] ryan dot brothers at gmail dot com
I ran into the above issue too trying to compile PHP 7.3.0RC2 on CentOS 7.  Using --without-libzip resolved it.  Should this be included in the upgrading notes in case others run into it too (https://github.com/php/php-src/blob/php-7.3.0RC2/UPGRADING)?
 [2018-10-08 10:50 UTC] cmb@php.net
> Should this be included in the upgrading notes in case others
> run into it too

Thanks! Done:
http://git.php.net/?p=php-src.git;a=commit;h=c5df679ca8b1373e3f2a47aeba5b37da74f993de
 [2019-03-20 06:19 UTC] mysamraat at gmail dot com
When compiling PHP 7.3.3 with --enable-zip and --without-libzip, I am getting the below output. 

checking for the location of zlib... /usr
configure: WARNING: ========================================================
configure: WARNING: Use of bundled libzip is deprecated and will be removed.
configure: WARNING: Some features such as encryption and bzip2 are not available.
configure: WARNING: Use system library and --with-libzip is recommended.
configure: WARNING: ========================================================

Otherwise, it says the libzip needs to be > 0.11 
I am using CentOS 7 for the installation. 
What could be done to upgrade libzip and also get bzip2 functionalities up as well? 
I am using 7.2.4 (installed and works fine) and compiling 7.3.3 on the same machine.
 [2019-03-20 06:44 UTC] pa at yourserveradmin dot com
> compiling 7.3.3 on the same machine

Have you tried to compile PHP 7.3.2 to see if your issue is caused by the latest patch version changes?
 [2019-03-20 06:47 UTC] pa at yourserveradmin dot com
To make the question cleat: prior to the 7.3.3 patch release builds successfully passed using the previously suggested combination of configuration flags.

So, in case this is just a configuration flags question, possible I'll be able to provide you with guarantee working set of flags.
 [2019-03-20 07:59 UTC] cmb@php.net
If you use --without-libzip, the deprecation notice is to be
expected, since this option will be removed in the future (PHP 7.4
or 8).

If you use --with-libzip, the installed libzip has to be ≥ 0.11.
If it is not, consider to update.
 [2019-05-10 04:14 UTC] forwork dot jan at gmail dot com
I have the same question

I have compile libzip-1.5.2 by cmake
mkdir build && cd build && cmake -DCMAKE_INSTALL_PREFIX=/usr/local/libzip .. && make install
echo "/usr/local/libzip/lib64" >> /etc/ld.so.conf && ldconfig

But in compile still fail
checking libzip... yes
checking for the location of zlib... /usr
checking for pkg-config... (cached) /bin/pkg-config
checking for libzip... not found
configure: error: Please reinstall the libzip distribution
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon May 20 18:01:27 2019 UTC