php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7645 get_class returns class names only in lower case
Submitted: 2000-11-05 04:47 UTC Modified: 2000-11-05 06:20 UTC
From: sb at sebastian-bergmann dot de Assigned:
Status: Closed Package: Class/Object related
PHP Version: 4.0 Latest CVS (05/11/2000) OS: Windows 2000 Professional
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: sb at sebastian-bergmann dot de
New email:
PHP Version: OS:

 

 [2000-11-05 04:47 UTC] sb at sebastian-bergmann dot de
class Foo_Bar
{
  // ...
}

$object = new Foo_Bar();
print get_class( $object );

// output: "foo_bar"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-05 06:20 UTC] stas@php.net
This is intended behaviour, class and function names are not case sensitive in PHP.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Feb 29 18:01:31 2024 UTC