php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76447 no autocomplete results for function names that do exist
Submitted: 2018-06-11 16:30 UTC Modified: 2021-03-03 11:47 UTC
From: teo8976 at gmail dot com Assigned: cmb (profile)
Status: Duplicate Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
38 - 31 = ?
Subscribe to this entry?

 
 [2018-06-11 16:30 UTC] teo8976 at gmail dot com
Description:
------------
In the search box at the top-right of the screen at http://php.net, type "mysqli_real" as if you were going to search for "mysql_real_escape_string"



Expected result:
----------------
The autocomplete should show a few clickable results:
- mysqli_real_escape_string
- mysqli_real_connect
- mysqli_real_query

All of these functions exist. They are aliases of MySQLi::real_escape_string() etc, but they do exist in the functional form. Also, if you do type the name blindly and correctly till the end, e.g. you type "mysqli_real_escape_string", and you hit Enter, the search engine does find the result and directs you to the relevant page: http://php.net/manual/en/mysqli.real-escape-string.php

Hence, the autocomplete should suggest those results.

Actual result:
--------------
It doesn't.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-06-12 19:30 UTC] philip@php.net
Related To: Bug #49956
Related To: Bug #73752

The problem applies to all OOP+Procedural documentation pages where methods and functions are documented on a single page. The tool that parses the documentation source fails to produce results for the procedural form.

In the scope of this report, the tool that generates search-index.json, such as the following copy for en/, requires an update:

  http://php.net/manual/en/search-index.json

The previous fixes were hacks that don't address the central problem (I added one such hack!) which is why this general issue remains.
 [2019-05-08 06:50 UTC] naitsirch at e dot mail dot de
The same goes for "locale_parse", which is documented together with Locale::parseLocale()

https://www.php.net/manual/en/locale.parselocale.php
 [2021-03-03 11:47 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2021-03-03 11:47 UTC] cmb@php.net
Duplicate of bug #49956.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Apr 11 07:01:24 2021 UTC