php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76404 Why isn't there an easy way to navigate to fgetc reference?
Submitted: 2018-06-02 01:14 UTC Modified: 2018-06-03 21:33 UTC
From: drankinatty at suddenlinkmail dot com Assigned: cmb (profile)
Status: Not a bug Package: Website problem
PHP Version: 7.2.6 OS: SuSE Leap 42.3
Private report: No CVE-ID: None
 [2018-06-02 01:14 UTC] drankinatty at suddenlinkmail dot com
Description:
------------
Guys (and girls),

  I have used a lot of technical references, as an engineer and attorney, and php.net is damn near impossible to navigate to find simple function references. I have to google to get to printf, and once there, there is no way to easily find a way to navigate to fgets or fgetc? Really.

  Your "Function Reference" isn't a function reference, instead it is a collection of extension and how to install them. Where is the simply "File I/O". Why is printf buried under "Strings" -- it has absolutely nothing to do with "strings" (other than being about to output one with the %s format-specifier.

  This is a great opportunity for improvement. A simple function reference for people looking to actually use real functions would greatly help. 

Expected result:
----------------
Just a simply function index - it can even just be an alphabetical dump of links to the functions. It would take a lot less time to scroll to 'f' than it currently does to play hide-and-go-seek across the php.net site looking for fgetc hidden somewhere.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-06-02 02:08 UTC] a at b dot c dot de
If you know you're looking for fgetc (which you would be if you knew you'd need to look under 'f' in an index) then http://www.php.net/fgetc will take you to the page.

If you don't know the name, then an alphabetical list wouldn't be any help, because all that would do is group functions together arbitrarily by the first letter of their names - which you don't have. On the other hand, some categorisation is required, since There are (let's see...) up to 4747 functions in global scope depending on which recognised extensions are installed, and that's not counting object methods.

> Where is the simply "File I/O".
Probably under "Filesystem related functions". If I were skimming the list (or, given the length, using ctrl-f and searching for "file") that would be the standout for me.

> Why is printf buried under "Strings" -- it has absolutely nothing to do with "strings" (other than being about to output one with the %s format-specifier.
It has even less to do with File I/O. It's a one-line wrapper around sprintf() (one line in the sense that every paragraph that describes it is a single line).
 [2018-06-02 10:33 UTC] danack@php.net
> Where is the simply "File I/O".

https://secure.php.net/manual/en/book.filesystem.php
 [2018-06-02 19:18 UTC] philip@php.net
Every php.net page has a search field in the header. Typing "fget" there reveals this:

------------------------
  Functions:           8
------------------------
fgetc
 Gets character from file pointer

fgetcsv
 Gets line from file pointer and parse for CSV fields

fgets
 Gets line from file pointer

fgetss
 Gets line from file pointer and strip HTML tags

SplFileObject::fgetc
 Gets character from file

SplFileObject::fgetcsv
 Gets line from file and parse as CSV fields

SplFileObject::fgets
 Gets line from file

SplFileObject::fgetss
 Gets line from file and strip HTML tags
------------------------
>> Search php.net for fget
------------------------

Otherwise it sounds like you're looking for this:

  Function and Method listing
  (List of all the functions and methods in the manual)

    http://php.net/manual/en/indexes.functions.php
 [2018-06-03 21:33 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2018-06-03 21:33 UTC] cmb@php.net
Considering that there are already several easy ways to navigate
to the fgetc() man page, I'd say, this is not a bug.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat May 21 23:03:34 2022 UTC