php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #76352 when as a key word for PHP
Submitted: 2018-05-17 21:01 UTC Modified: 2018-05-18 08:53 UTC
From: olgamg at tpg dot com dot au Assigned:
Status: Not a bug Package: Online Doc Editor problem
PHP Version: 7.1.17 OS: windows 10
Private report: No CVE-ID: None
 [2018-05-17 21:01 UTC] olgamg at tpg dot com dot au
Description:
------------
---
From manual page: http://www.php.net/reserved.keywords
---


I'd created table with field named => when =>, during simple INSERT all the time syntax error =>  After changing field name when => wheny (yes, really weird word) no problems at all. I do not see =>when => listed as a Key word in the List of Keywords for PHP.  Maybe someone will check it, if the => when => word is another new key word of the PHP.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-05-17 21:11 UTC] peehaa@php.net
-Status: Open +Status: Not a bug
 [2018-05-17 21:12 UTC] peehaa@php.net
I guess you are looking for the documentation of your database system instead.
 [2018-05-18 00:40 UTC] olgamg at tpg dot com dot au
I am looking exactly at 

http://www.php.net/reserved.keywords (not my "home manual".

And I see only one reserved.keyword started with letter W and this is while.

I do not see another word started with letter w at all. Then where can I find if when is or is not the keywords reserved. Sorry about the confusion.
 [2018-05-18 00:53 UTC] requinix@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Your problem has nothing to do with PHP.
https://dev.mysql.com/doc/refman/8.0/en/keywords.html#keywords-8-0-detailed-W
 [2018-05-18 08:53 UTC] olgamg at tpg dot com dot au
Thank you so much for that link. 

https://dev.mysql.com/doc/refman/8.0/en/keywords.html#keywords-8-0-detailed-W 

It was very helpful to clarify the confusion.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Apr 22 20:01:25 2019 UTC