php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76348 WSDL_CACHE_MEMORY causes Segmentation fault
Submitted: 2018-05-16 12:42 UTC Modified: 2018-11-04 15:50 UTC
From: mati at we dot ee Assigned: cmb (profile)
Status: Closed Package: SOAP related
PHP Version: 7.2Git-2018-05-16 (Git) OS: x86_64 GNU/Linux
Private report: No CVE-ID: None
 [2018-05-16 12:42 UTC] mati at we dot ee
Description:
------------
WSDL_CACHE_MEMORY causes Segmentation fault on Debian or Ubuntu.
WHen removing part "<soap:header message="tns:requestheader" part="id" use="literal"/>" wsdl SoapClient constructs successfully.
Similar to https://bugs.php.net/bug.php?id=71931 witch is marked as duplicate of
https://bugs.php.net/bug.php?id=75502.



Test script:
---------------
https://bitbucket.org/matiwe/wsdl_cache_memory-causes-segmentation-fault


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-11-03 12:39 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2018-11-03 12:39 UTC] cmb@php.net
<https://bitbucket.org/matiwe/wsdl_cache_memory-causes-segmentation-fault>
is apparently dead.  Please post the test script to this ticket,
or set it up somewhere else, so it can be seen.
 [2018-11-03 15:04 UTC] mati at we dot ee
-Status: Feedback +Status: Assigned
 [2018-11-04 15:49 UTC] cmb@php.net
Automatic comment on behalf of cmbecker69@gmx.de
Revision: http://git.php.net/?p=php-src.git;a=commit;h=625f614cb13536d805985a2008840452c6c86a26
Log: Fix #76348: WSDL_CACHE_MEMORY causes Segmentation fault
 [2018-11-04 15:49 UTC] cmb@php.net
-Status: Assigned +Status: Closed
 [2018-11-04 15:50 UTC] cmb@php.net
Thank you for the report, and for helping us make PHP better.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Thu Dec 13 22:01:26 2018 UTC