php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76262 phpinfo() show wrong version
Submitted: 2018-04-24 18:59 UTC Modified: 2018-04-25 14:14 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: arlyna dot bridges at ebix dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 7.1.16 OS: Windows 7
Private report: No CVE-ID: None
 [2018-04-24 18:59 UTC] arlyna dot bridges at ebix dot com
Description:
------------
The version number of the PHP package: 7.1.16
Zip package downloaded from: https://windows.php.net/download/ PHP 7.1 (7.1.16) (VC14 x86 Thread Safe (2018-Mar-29 06:18:44))

Apache: httpd-2.4.27-win32-VC14
Apache was previously working with PHP7.1.8 - and has this configuration:
LoadModule php7_module "d:/php/php7.1.8/php7apache2_4.dll"
PHPIniDir "d:/php/php7.1.8" 

Now, the apache configuration is updated to:
LoadModule php7_module "d:/php/php7.1.16/php7apache2_4.dll"
PHPIniDir "d:/php/php7.1.16"

Apache service was stopped and started. 

The old php folder (d:/php/php7.1.8) is deleted.

When running phpinfo() on web browser, it's showing old version & build date ( PHP Version 7.1.8 with build date: Aug 1 2017 20:56:01) 

But on the apache2handler section, it's showing Apache running with the correct PHP 7.1.16.
Apache Version = Apache/2.4.27 (Win32) OpenSSL/1.0.2l PHP/7.1.16  



 




Test script:
---------------
<?php
phpinfo();
?>

Expected result:
----------------
Version: PHP Version 7.1.16
Build Date: Mar 29 2018

Actual result:
--------------
Version: PHP Version 7.1.8
Build Date: Aug 1 2017 20:56:01 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-04-25 14:14 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2018-04-25 14:14 UTC] ab@php.net
Thanks for the report. I've checked the 7.1.16 builds and they show the correct version in the phpinfo(). There's only one source of the version that is used anywhere in the core. Thus, you likely to experience some configuration issue on your side. Please use the user support channels for the further assistance.

Thanks.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 19 13:04:05 2022 UTC