php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #76237 Missing Info
Submitted: 2018-04-18 15:45 UTC Modified: 2018-04-18 16:23 UTC
From: hdk at it-center dot at Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: Irrelevant OS: any
Private report: No CVE-ID: None
 [2018-04-18 15:45 UTC] hdk at it-center dot at
Description:
------------
Hi!

If I encounter e.g. the error msg from my website "PHP Fatal error:  Call to undefined function apache_note()" I go to php.net/manual/de/function.apache-note.php and read the description.


The one thing I really miss there:
No mentioning of: "These functions are only available when running PHP as an Apache module."

Please add that info to the php-apache-functions!


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-04-18 15:51 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2018-04-18 15:51 UTC] requinix@php.net
http://php.net/manual/de/intro.apache.php
> Diese Funktionen stehen nur zur Verfügung, wenn PHP als Apachemodul läuft.

Information like that is documented once for the entire section so it does not have to be repeated on every page.
 [2018-04-18 16:06 UTC] hdk at it-center dot at
if this info was found in http://php.net/manual/de/ref.apache.php or one more step up in http://php.net/manual/de/ref.apache.php or even one more step up in http://php.net/manual/de/book.apache.php ok. But come on, it is hidden in "Introduction" (http://php.net/manual/de/intro.apache.php) .. no one reads introductions!
At least add an asterisk or some kind of visual hint to these functions, to raise peoples attention that something could be different here.
 [2018-04-18 16:23 UTC] requinix@php.net
Whether *anything* is available depends on the setup. For example, on Linux the vast majority of functions are normally bundled into packages that need to be installed - even the functions that PHP says are built-in and don't require installation. Should 95% of functions in the manual have asterisks? How would anyone know what that asterisk even meant?

The ref.apache.php and book.apache.php are index pages. They have links to the pages that have the real documentation. Pages that people spend time writing, editing, and translating. Pages that you, as a developer, are expected to read. So have you considered that the problem is not that you didn't see the note on the page you looked at, but that you didn't look anywhere else?

All of that aside, if you want to ask for major changes to the docs then you need to talk to the docs mailing list.
http://php.net/mailing-lists.php
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 01 13:05:53 2022 UTC