php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76192 lstat cannot parse an url right
Submitted: 2018-04-06 13:14 UTC Modified: 2018-04-06 17:58 UTC
From: pupiles86 at gmail dot com Assigned:
Status: Not a bug Package: *Web Server problem
PHP Version: 7.0.29 OS: Linux
Private report: No CVE-ID: None
 [2018-04-06 13:14 UTC] pupiles86 at gmail dot com
Description:
------------
lstat function cannot parse a file when an inexistence directory in path

Test script:
---------------
<?php
print_r(lstat('/var/www/html/x/../index.php'));
?>

Expected result:
----------------
Array ( [0] => 51713 [1] => 57933 [2] => 33188 [3] => 1 [4] => 0 [5] => 0 [6] => 0 [7] => 43 [8] => 1523008076 [9] => 1523008073 [10] => 1523008073 [11] => 4096 [12] => 8 [dev] => 51713 [ino] => 57933 [mode] => 33188 [nlink] => 1 [uid] => 0 [gid] => 0 [rdev] => 0 [size] => 43 [atime] => 1523008076 [mtime] => 1523008073 [ctime] => 1523008073 [blksize] => 4096 [blocks] => 8 ) 

Actual result:
--------------
None

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-04-06 17:58 UTC] aharvey@php.net
-Status: Open +Status: Not a bug
 [2018-04-06 17:58 UTC] aharvey@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 24 04:03:36 2021 UTC