php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #76177 Can't install MongoDb on macOS using Homebrew
Submitted: 2018-04-02 08:45 UTC Modified: 2019-01-01 22:12 UTC
Votes:3
Avg. Score:4.3 ± 0.9
Reproduced:3 of 3 (100.0%)
Same Version:2 (66.7%)
Same OS:2 (66.7%)
From: 421034509 at qq dot com Assigned: girgias (profile)
Status: Closed Package: mongodb (PECL)
PHP Version: Irrelevant OS: macOS
Private report: No CVE-ID: None
 [2018-04-02 08:45 UTC] 421034509 at qq dot com
Description:
------------
---
From manual page: http://www.php.net/mongodb.installation.homebrew
---
we can't 'brew install php71-mongodb' if we want install the driver for PHP 7.1

if you run that commond you will get an error:
Error: No available formula with the name "homebrew/php/php71-mongodb".

That is because homebrew/php/php71-mongodb was deleted from homebrew/php in commit 3adb72d1:Deprecate tap.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-04-03 13:41 UTC] okanck at gmail dot com
Hi there,

I have solved the issue with the instructions below:

brew tap kyslik/php
brew install phpxx-mongo

I hope this helps for you too.
 [2018-04-13 18:01 UTC] Brett dot Santore at gmail dot com
This is a homebrew related issue anyway.
 [2018-04-19 23:05 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2018-04-19 23:05 UTC] cmb@php.net
> This is a homebrew related issue anyway.

That!
 [2018-04-20 00:50 UTC] requinix@php.net
-Status: Not a bug +Status: Open -Assigned To: cmb +Assigned To:
 [2018-04-20 00:50 UTC] requinix@php.net
If homebrew-php isn't available anymore then the docs do need to be updated to say something else. But kyslik/php isn't exactly an official source, and there are hundreds of forks of homebrew-php...
 [2019-01-01 22:12 UTC] girgias@php.net
-Summary: we can't install php71-mongodb using this commond +Summary: Can't install MongoDb on macOS using Homebrew -Status: Open +Status: Closed -PHP Version: 7.1Git-2018-04-02 (Git) +PHP Version: Irrelevant -Assigned To: +Assigned To: girgias
 [2019-01-01 22:12 UTC] girgias@php.net
Doc seems fixed
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Dec 05 12:03:38 2021 UTC