php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #76148 Add array_key_exists() to the list of specialy compiled functions
Submitted: 2018-03-26 07:22 UTC Modified: 2020-01-29 15:55 UTC
Votes:7
Avg. Score:4.7 ± 0.5
Reproduced:4 of 4 (100.0%)
Same Version:2 (50.0%)
Same OS:1 (25.0%)
From: nicolas dot grekas+php at gmail dot com Assigned: nikic (profile)
Status: Closed Package: Scripting Engine problem
PHP Version: master-Git-2018-03-26 (Git) OS:
Private report: No CVE-ID: None
 [2018-03-26 07:22 UTC] nicolas dot grekas+php at gmail dot com
Description:
------------
zend_compile.c (zend_try_compile_special_func() in https://github.com/php/php-src/blob/master/Zend/zend_compile.c) turns come function calls into direct opcode operations.

It would be great to add array_key_exists() to the list, because this function is  used quite often in tight loops, for its ability to check nulled values in arrays (contrary to isset()).


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-03-26 07:54 UTC] nicolas dot grekas+php at gmail dot com
Similar to https://bugs.php.net/71239
 [2018-08-08 15:07 UTC] nicolas dot grekas+php at gmail dot com
Implemented in https://github.com/php/php-src/pull/3360
 [2020-01-29 15:49 UTC] love at sickpeople dot se
This and the related bug can be closed now as of PHP 7.4.
 [2020-01-29 15:55 UTC] nikic@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: nikic
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Aug 08 13:01:26 2020 UTC