php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76137 config.guess/config.sub do not recognize RISC-V
Submitted: 2018-03-22 12:39 UTC Modified: 2018-05-15 14:40 UTC
From: rjones at redhat dot com Assigned:
Status: Closed Package: *General Issues
PHP Version: master-Git-2018-03-22 (Git) OS: Linux
Private report: No CVE-ID: None
 [2018-03-22 12:39 UTC] rjones at redhat dot com
Description:
------------
The versions of config.guess and config.sub are too old and do not recognize the RISC-V architectures.  Please update them to the latest upstream versions.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-05-08 21:03 UTC] cmb@php.net
-Summary: Please update config.guess and config.sub +Summary: config.guess/config.sub do not recognize RISC-V
 [2018-05-08 21:03 UTC] cmb@php.net
Thanks for the reminder!  I've submitted a respective pull
request[1].  Could you please verify whether this properly detects
RISC-V?

[1] <https://github.com/php/php-src/pull/3236>
 [2018-05-15 14:40 UTC] rjones at redhat dot com
Yes this works, added a comment to the github PR.
 [2018-05-25 13:27 UTC] cmb@php.net
Automatic comment on behalf of cmbecker69@gmx.de
Revision: http://git.php.net/?p=php-src.git;a=commit;h=e265a96d934ff2f0e1b04aa2e82684f08484672c
Log: Fix #76137: config.guess/config.sub do not recognize RISC-V
 [2018-05-25 13:27 UTC] cmb@php.net
-Status: Open +Status: Closed
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Thu Dec 13 22:01:26 2018 UTC